Popup menus displayed in English if another locale is system default

RESOLVED DUPLICATE of bug 1418417

Status

()

defect
RESOLVED DUPLICATE of bug 1418417
2 years ago
2 years ago

People

(Reporter: nico, Unassigned)

Tracking

58 Branch
Unspecified
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Hello,

Since Firefox for Android 58.0b5 version released today on Play Store, if the "system default" language is selected, popup menus (on long-press on links) and copy/paste menus (on long-press on selectable text or input field) are in English whereas the rest of Firefox is in the correct locale.

This has at least been reproduced with Android on fr-fr locale, on three different devices.

Steps to reproduce:
1. Switch your Android device language to "French (France)"
2. Start Firefox, open Wikipedia for instance.
3. Long press a link or image.
4. See below.
5. Long press the search field.
6. See below.

What happens:
4. Popup menu entries is displayed in English, see capture here: https://forums.mozfr.org/viewtopic.php?f=24&t=135680&p=854049#p854017
6. Copy, paste, etc. popup menu appears, in English.

What should happen:
4 and 6. Popup menu entries should be displayed in French

I noticed that when switching Firefox locale to "French" instead of "system default", the popup menu is displayed in the correct language. But when switching back to "system default" and restarting Firefox, popup menus are in English again.

Possibly related to bug 1399573 ?
I’d suspect a dupe of bug 1399573 too, but I’m not able to confirm. Like in the other bug, pinging Zibi for awareness and he should be able to tell if those are dupes
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gandalf)
I add that I don't reproduce the issue in Firefox 57, but I do in 58.0b3, 58.0b5 and the last Nightly (59.0a1 2017-11-22).

(In reply to Théo Chevalier [:tchevalier] from comment #1)
> I’d suspect a dupe of bug 1399573 too, but I’m not able to confirm.
After checking, there is no problem with the "three dots" menu in tabs tray mentioned in bug 1399573: it is correctly displayed in French.
Or maybe bug 1418417?
(In reply to Jan Henning [:JanH] from comment #3)
> Or maybe bug 1418417?

Actually, the items mentioned in this bug (start page "tip" and about:firefox) are untranslated in the affected versions in French too.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1418417
Flags: needinfo?(gandalf)
You need to log in before you can comment on or make changes to this bug.