ID .gitignore entry ignores "id" locale (for mac)

RESOLVED FIXED in Firefox 59

Status

enhancement
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

Trunk
mozilla59

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

2 years ago
There's currently a .gitignore entry of "ID" that is generated by idutils and actively used today but causes problems with git on mac because `[core] ignorecase = true` for "id" locale (Indonesian Bahasa Indonesia).

Standard8 added the .gitignore unignore entry for screenshots see 1346825 comment 15. I added one for activity stream in bug 1419601 after forgetting to update it in bug 1413550.

That forgetting has resulted in almost 3 weeks of Nightly 58/59 being broken for "id" users and about 1 week of Beta 58 so far (although the next beta build 58.0b6 is after US Thanksgiving, so it'll be broken for about 2 weeks).

Ideally we avoid these types of failures more generally maybe by scoping .gitignore ID to directories that might be used with idutils.

bz from irc:
> There are people who use idutils with Gecko/SpiderMonkey, yes
> I mean, their generation is not an automatic process, but it sure does make searching nicer in some cases
> The problem is that the mac filesystem is case-insensitive
> I wonder whether we can restrict the ID ignoring to ID in the root and in the spidermonkey root
> It's hard to say where else people might decide to run idutils...
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8931034 [details]
Bug 1419836 - ID .gitignore entry ignores "id" locale (for mac).

https://reviewboard.mozilla.org/r/202134/#review207516

Thanks for tracking this down.
Attachment #8931034 - Flags: review?(standard8) → review+

Comment 3

2 years ago
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9080f4819e7d
ID .gitignore entry ignores "id" locale (for mac). r=standard8

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9080f4819e7d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59

Updated

Last year
Product: Core → Firefox Build System
Assignee: nobody → edilee
You need to log in before you can comment on or make changes to this bug.