Closed Bug 1420065 Opened 4 years ago Closed 4 years ago

Add to home screen annoying

Categories

(Firefox for Android Graveyard :: General, enhancement, P3)

All
Android
enhancement

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 1444984
Tracking Status
fennec + ---

People

(Reporter: fre.and.fri, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (Android 8.0.0; Mobile; rv:58.0) Gecko/58.0 Firefox/58.0
Build ID: 20171121001048

Steps to reproduce:

On an Android device, install Firefox for Android beta (currently says version is 58)
Open eg https://en.m.wikipedia.org/wiki/Wikipedia


Actual results:

Between URL bar and Reader Mode icon there is an annoying add to home screen icon, and there is no apparent means to remove it


Expected results:

There is no annoying add to home screen icon OR at least there is some means to remove it

While I can see the usefulness of an add to home screen icon, adding something to home screen is so rare it makes no sense to have such a prominent button for it, let alone in such a frequently used area of the screen, where there's a substantial risk of accidentally pressing it when actually intending to press the URL bar or Reader Mode button
Maybe a toggle could be added? Something like the QR code reader or Voice input in Accessibility.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → All
See Also: → 1285858
Version: unspecified → Trunk
(In reply to Bogdan Surd, QA [PTO From 11/24 to 12/03, :BogdanS, NI] from comment #1)
> Maybe a toggle could be added? Something like the QR code reader or Voice
> input in Accessibility.

An about:config item that determines the visibility of the add to home screen button would be enough for me, but as far as I know, there is currently no such about:config item.

A GUI means to remove it would be nice too.
Unless Product think it's important, it's a P3
tracking-fennec: ? → +
Flags: needinfo?(jcheng)
Priority: -- → P3
+1 for this, I've no idea how it got added to the main interface, how often will it be used exactly? It should be somewhere in the menu. I'd argue that the same should be said for the Reader icon.
Reader is likely used much more often to justify it's place. But, this add to home button has limited usefulness. Say, I visit Twitter and see this button. But, instead of creating a home screen shortcut, I choose to continue to load it in Firefox browser. It implies, I have no intention whatsoever to use this button. And, it's wasting precious screen real estate; especially when our phones are losing horizontal space. Very bad UI decision.
bug 1444984 is a duplicate of this bug.

There's also an r/firefox thread where people seem to be keen to get rid of this button:-

https://www.reddit.com/r/firefox/comments/92vuo9/is_there_a_way_to_customize_firefox_for_android_i/

Hope you can do something to get rid of it. Thanks
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1444984
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.