Permanent false-positive /streams/readable-byte-streams/detached-buffers.dedicatedworker.html | application crashed [@ TransferArrayBuffer]

RESOLVED FIXED in Firefox 60

Status

()

defect
--
critical
RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: intermittent-bug-filer, Assigned: jorendorff)

Tracking

({crash, intermittent-failure})

unspecified
mozilla61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 wontfix, firefox60 fixed, firefox61 fixed)

Details

(crash signature)

Attachments

(1 attachment)

See Also: → 1411820
Summary: Intermittent /streams/readable-byte-streams/detached-buffers.dedicatedworker.html | application crashed [@ TransferArrayBuffer] → Permanent false-positive /streams/readable-byte-streams/detached-buffers.dedicatedworker.html | application crashed [@ TransferArrayBuffer]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
On debug runs, there's also an assertion coming along for the ride:
Assertion failure: !JS_IsDetachedArrayBufferObject(buffer), at z:/build/build/src/js/src/builtin/Stream.cpp:5141

Till, can you please take a look at this?
Component: web-platform-tests → JavaScript Engine
Flags: needinfo?(till)
Product: Testing → Core
See Also: → 1424549
Version: Version 3 → unspecified
Duplicate of this bug: 1424527
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1445487
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Disabling this and the other worker variants on Windows since for some reason the trees are orange, even though the failures are "expected".

In any case I expect we should fix the underlying assert here since that's a real bug.
I also bundled in disabling the construct-byob-request*.html crashes on Windows, since they seem to be probably the same bug.
Dunno why this was set to P5, but a reproducable assert/crash seems like it should be properly triaged.
Priority: P5 → --
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Jason, this looks like a 100% reproducible crash we're hitting in web-platform-tests. Can you maybe help find an owner for it?
Flags: needinfo?(jorendorff)
<till> jorendorff: we should just disable it, because byte streams go away with the patch you're reviewing
Assignee

Updated

Last year
Assignee: nobody → jorendorff
Status: NEW → ASSIGNED
Comment on attachment 8968656 [details] [diff] [review]
Fix permanent crash [@ TransferArrayBuffer] in /streams/readable-byte-streams/detached-buffers.dedicatedworker.html

Review of attachment 8968656 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me, thank you for doing this!
Attachment #8968656 - Flags: review?(till) → review+
Flags: needinfo?(till)
Flags: needinfo?(jorendorff)
https://hg.mozilla.org/integration/mozilla-inbound/rev/405a7e528aeb6194cac28b860e2b2cc15a7b4738
Bug 1420076 - Fix permanent crash [@ TransferArrayBuffer] in /streams/readable-byte-streams/detached-buffers.dedicatedworker.html. r=till.

Comment 34

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/405a7e528aeb
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Whiteboard: [checkin-needed-beta]
Duplicate of this bug: 1455129
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.