Opens new window without URL bar

RESOLVED DUPLICATE of bug 151142

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 151142
16 years ago
14 years ago

People

(Reporter: Karl Vogel, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020501
BuildID:    2002050106

When clicking an image on this page (to preview the screenshot of the theme)
while holding down the CTRL key, a new browser window is opened (which by itself
is wrong) without an URL bar

Reproducible: Always
Steps to Reproduce:
1. Open URL http://themes.freshmeat.net/browse/918/?topic_id=918
2. CTRL+left mouse button click one of the screenshots


Actual Results:  A new tab is opened with the screenshot, but also a new browser
window is opened. The new browser window doesn't contain an URL bar

Expected Results:  Only a new browser tab should be opened (tabbed browsing)

Scripts & Window setting:
Are OFF:
- Open unrequested windows
- Open a link in a new window

The other options are ON.
(Reporter)

Comment 1

16 years ago
Created attachment 82196 [details]
Screenshot of new browser window

Comment 2

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020502

I think, this bug is INVALID:
You will have similar results with IE6, NN4.73, OPERA6 (all tested), this is a
special "Trick"  (javascript (?)), which enables URL-bar and other functions.
(Reporter)

Comment 3

16 years ago
Seems I was a bit hasty when logging this bug. The page uses javascript to open
another window without URL bar:
  
onclick="window.open('','screenshot','resizable=yes,status=yes,toolbar=yes,location=no,scrollbars=yes')

But it was confusing as I use tabbed browsing and the actual html result was
shown in a new TAB. 

Should this be a special case to handle in the tabbed browsing?!
The image has an onclick handler that is triggered by any click... not sure
whether this gets fired before the contentAreaClick stuff or after....  If
after, we should cancel the event.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → pmac

Comment 5

15 years ago
I'd vote for invalid here in its current form... if you thing theres a problem
with events order i would think that should be another bug entirely

Comment 6

14 years ago
Resolving as dupe of bug 151142, since that should fix the reported behaviour.

*** This bug has been marked as a duplicate of 151142 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Tabbed Browser → DOM Events
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.