Closed Bug 1420150 Opened 2 years ago Closed 2 years ago

too high resolution favicon used for bookmarks [regression]

Categories

(Toolkit :: Places, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1347532

People

(Reporter: ossman, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171113102034

Steps to reproduce:

Somewhat similar to bug 1419039, but involves bookmarks and doesn't involve SVG.

With Firefox 57 you get really **** icons for bookmarks on many sites. After some testing I figured out that Firefox is now picking a high resolution icon to use as the bookmark icon, and not a 16x16 one which was the previous behaviour.
Component: Untriaged → Places
Product: Firefox → Toolkit
Most of the behavior is fixed in Firefox 58 beta, so please try that one. The remaining things to evaluate are bug 1359487 and bug 1419039, so this is likely just a dupe of one of those.
I'm duping to bug 1347532 that should have fixed most cases, please refer to the bugs I linked in comment 1 for further issues.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1347532
I tested the nightly whilst testing another bug, and this does indeed seem to be fixed. Do you want me to test 58 as well?

I've also noticed that the wrong favicon gets associated with a bookmark entry if you click that entry whilst loading a different page. Is that also fixed or should I open another bug?
58 and 59 have pretty much the same behavior.

(In reply to Pierre Ossman from comment #3)
> I've also noticed that the wrong favicon gets associated with a bookmark
> entry if you click that entry whilst loading a different page. Is that also
> fixed or should I open another bug?

That's new to me, favicons should always be associated with a specific docshell, there should be no relation with clicking bookmarks. If you have consistent steps to reproduce, please file a bug.
Unfortunately I can not easily reproduce this. I have however a couple of entries that are screwed up and aren't fixing themselves, so is there some post-mortem debugging that could be valuable on those?

I'm trying to poke around in the SQLite database, but the information there doesn't seem to match the documentation. E.g. the moz_favicons table is empty.
favicons are now stored in favicons.sqlite
How are the references handled?

Is there any new documentation for the database structure?
there is a pages_w_icons tables with urls that are the same urls in places.sqlite, a relation table connecting pages to icons and an icons table. Nothing fancy.
All the tables definitions are here:
https://searchfox.org/mozilla-central/source/toolkit/components/places/nsPlacesTables.h

Sorry for the documentation, I'm honestly lacking the time to write some good one apart from the code inline one.
No worries, I know what it is like keeping multiple places updated. :)

So I've had a look in the tables, and it confirms the broken behaviour that is seen:

> sqlite> select * from moz_pages_w_icons inner join moz_icons_to_pages on id = page_id where icon_id = 6140;
> 15541|https://www.reddit.com/|47359719085711|15541|6140
> 19050|https://intranet.lkpg.cendio.se/|47357317736854|19050|6140
> ... (a whole bunch of more reddit URLs)

Every other page for intranet.lkpg.cendio.se has icon id 1. I'm also getting the correct icon for the tab.

There doesn't seem to enough info here to speculate on why it went wrong. But why isn't it resolving itself? When is moz_pages_w_icons updated? It's been broken for months.

I do have one more clue though. There is actually a correct mapping entry as well:

> sqlite> select * from moz_pages_w_icons inner join moz_icons_to_pages on id = page_id where page_url = 'https://intranet.lkpg.cendio.se/';
> 19050|https://intranet.lkpg.cendio.se/|47357317736854|19050|1
> 19050|https://intranet.lkpg.cendio.se/|47357317736854|19050|6140
> 19050|https://intranet.lkpg.cendio.se/|47357317736854|19050|6167
the only idea I have is the special redirect behavior we have, where if a page is bookmarked that redirects to another page, the source page takes the icon of the target.
There is also the possibility these are some kind of leftovers from migrating the icons from the old db to the new one... Most of the cases I've seen stated it didn't happen anymore after regenerating a new favicons.sqlite...

Could you please file a separate bug for the reddit problem? We should look into it, since I've seen it reported by multiple users.
Filed as bug 1428751.
You need to log in before you can comment on or make changes to this bug.