Closed Bug 1420189 Opened 2 years ago Closed 2 years ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/actions/key_shortcuts.py | expected OK

Categories

(Testing :: geckodriver, defect, P1)

Version 3
defect

Tracking

(firefox59 disabled, firefox60 disabled)

RESOLVED FIXED
mozilla60
Tracking Status
firefox59 --- disabled
firefox60 --- disabled

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

Details

(Keywords: intermittent-failure, test-disabled)

Attachments

(1 file)

This failure is in `session.start()`, and we receive `unknown error (500)` as response:

[task 2017-11-22T11:59:46.868Z] 11:59:46     INFO - TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/actions/key_shortcuts.py | expected OK
[task 2017-11-22T11:59:46.868Z] 11:59:46     INFO - TEST-INFO took 80197ms
[task 2017-11-22T11:59:46.965Z] 11:59:46     INFO - STDOUT: ERROR
[task 2017-11-22T11:59:46.966Z] 11:59:46     INFO - STDOUT: tests/web-platform/tests/webdriver/tests/actions/key_shortcuts.py::test_mod_a_mod_x_deletes_all_text 
[task 2017-11-22T11:59:47.108Z] 11:59:47     INFO - STDOUT: ERROR
[task 2017-11-22T11:59:47.109Z] 11:59:47     INFO - STDOUT: ==================================== ERRORS ====================================
[task 2017-11-22T11:59:47.111Z] 11:59:47     INFO - STDOUT: _________ ERROR at setup of test_mod_a_and_backspace_deletes_all_text __________
[task 2017-11-22T11:59:47.112Z] 11:59:47     INFO - STDOUT: configuration = {'capabilities': {'moz:firefoxOptions': {'binary': '/builds/worker/workspace/build/application/firefox/firefox', 'pref...m.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test,xn--lve-6lad.web-platform.test'}}}, 'host': '127.0.0.1', 'port': 4444}
[task 2017-11-22T11:59:47.112Z] 11:59:47     INFO - STDOUT: request = <SubRequest 'session' for <Function 'test_mod_a_and_backspace_deletes_all_text'>>
[task 2017-11-22T11:59:47.114Z] 11:59:47     INFO - STDOUT:     def session(configuration, request):
[task 2017-11-22T11:59:47.114Z] 11:59:47     INFO - STDOUT:         """Create and start a session for a test that does not itself test session creation.
[task 2017-11-22T11:59:47.115Z] 11:59:47     INFO - STDOUT:     
[task 2017-11-22T11:59:47.116Z] 11:59:47     INFO - STDOUT:         By default the session will stay open after each test, but we always try to start a
[task 2017-11-22T11:59:47.117Z] 11:59:47     INFO - STDOUT:         new one and assume that if that fails there is already a valid session. This makes it
[task 2017-11-22T11:59:47.117Z] 11:59:47     INFO - STDOUT:         possible to recover from some errors that might leave the session in a bad state, but
[task 2017-11-22T11:59:47.118Z] 11:59:47     INFO - STDOUT:         does not demand that we start a new session per test."""
[task 2017-11-22T11:59:47.118Z] 11:59:47     INFO - STDOUT:         global _current_session
[task 2017-11-22T11:59:47.119Z] 11:59:47     INFO - STDOUT:         if _current_session is None:
[task 2017-11-22T11:59:47.120Z] 11:59:47     INFO - STDOUT:             _current_session = webdriver.Session(configuration["host"],
[task 2017-11-22T11:59:47.120Z] 11:59:47     INFO - STDOUT:                                                  configuration["port"],
[task 2017-11-22T11:59:47.121Z] 11:59:47     INFO - STDOUT:                                                  capabilities={"alwaysMatch": configuration["capabilities"]})
[task 2017-11-22T11:59:47.121Z] 11:59:47     INFO - STDOUT:         try:
[task 2017-11-22T11:59:47.122Z] 11:59:47     INFO - STDOUT: >           _current_session.start()
[task 2017-11-22T11:59:47.122Z] 11:59:47     INFO - STDOUT: configuration = {'capabilities': {'moz:firefoxOptions': {'binary': '/builds/worker/workspace/build/application/firefox/firefox', 'pref...m.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test,xn--lve-6lad.web-platform.test'}}}, 'host': '127.0.0.1', 'port': 4444}
[task 2017-11-22T11:59:47.123Z] 11:59:47     INFO - STDOUT: request    = <SubRequest 'session' for <Function 'test_mod_a_and_backspace_deletes_all_text'>>
[task 2017-11-22T11:59:47.124Z] 11:59:47     INFO - STDOUT: tests/web-platform/tests/webdriver/tests/support/fixtures.py:159: 
[task 2017-11-22T11:59:47.124Z] 11:59:47     INFO - STDOUT: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2017-11-22T11:59:47.125Z] 11:59:47     INFO - STDOUT: tests/web-platform/tests/tools/webdriver/webdriver/client.py:395: in start
[task 2017-11-22T11:59:47.126Z] 11:59:47     INFO - STDOUT:     value = self.send_command("POST", "session", body=body)
[task 2017-11-22T11:59:47.126Z] 11:59:47     INFO - STDOUT: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ 
[task 2017-11-22T11:59:47.127Z] 11:59:47     INFO - STDOUT: self = <webdriver.client.Session object at 0x7f7fab7a1490>, method = 'POST'
[task 2017-11-22T11:59:47.128Z] 11:59:47     INFO - STDOUT: url = 'session'
[task 2017-11-22T11:59:47.128Z] 11:59:47     INFO - STDOUT: body = {'capabilities': {'alwaysMatch': {'moz:firefoxOptions': {'binary': '/builds/worker/workspace/build/application/firefox...web-platform.test,www2.web-platform.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test,xn--lve-6lad.web-platform.test'}}}}}
[task 2017-11-22T11:59:47.129Z] 11:59:47     INFO - STDOUT:     def send_command(self, method, url, body=None):
[task 2017-11-22T11:59:47.130Z] 11:59:47     INFO - STDOUT:         """
[task 2017-11-22T11:59:47.130Z] 11:59:47     INFO - STDOUT:             Send a command to the remote end and validate its success.
[task 2017-11-22T11:59:47.131Z] 11:59:47     INFO - STDOUT:     
[task 2017-11-22T11:59:47.132Z] 11:59:47     INFO - STDOUT:             :param method: HTTP method to use in request.
[task 2017-11-22T11:59:47.133Z] 11:59:47     INFO - STDOUT:             :param uri: "Command part" of the HTTP request URL,
[task 2017-11-22T11:59:47.134Z] 11:59:47     INFO - STDOUT:                 e.g. `window/rect`.
[task 2017-11-22T11:59:47.135Z] 11:59:47     INFO - STDOUT:             :param body: Optional body of the HTTP request.
[task 2017-11-22T11:59:47.136Z] 11:59:47     INFO - STDOUT:     
[task 2017-11-22T11:59:47.137Z] 11:59:47     INFO - STDOUT:             :return: `None` if the HTTP response body was empty, otherwise
[task 2017-11-22T11:59:47.138Z] 11:59:47     INFO - STDOUT:                 the `value` field returned after parsing the response
[task 2017-11-22T11:59:47.139Z] 11:59:47     INFO - STDOUT:                 body as JSON.
[task 2017-11-22T11:59:47.140Z] 11:59:47     INFO - STDOUT:     
[task 2017-11-22T11:59:47.141Z] 11:59:47     INFO - STDOUT:             :raises ValueError: If the response body does not contain a
[task 2017-11-22T11:59:47.142Z] 11:59:47     INFO - STDOUT:                 `value` key.
[task 2017-11-22T11:59:47.143Z] 11:59:47     INFO - STDOUT:             :raises error.WebDriverException: If the remote end returns
[task 2017-11-22T11:59:47.144Z] 11:59:47     INFO - STDOUT:                 an error.
[task 2017-11-22T11:59:47.145Z] 11:59:47     INFO - STDOUT:             """
[task 2017-11-22T11:59:47.146Z] 11:59:47     INFO - STDOUT:         response = self.transport.send(
[task 2017-11-22T11:59:47.147Z] 11:59:47     INFO - STDOUT:             method, url, body,
[task 2017-11-22T11:59:47.148Z] 11:59:47     INFO - STDOUT:             encoder=protocol.Encoder, decoder=protocol.Decoder,
[task 2017-11-22T11:59:47.149Z] 11:59:47     INFO - STDOUT:             session=self)
[task 2017-11-22T11:59:47.150Z] 11:59:47     INFO - STDOUT:     
[task 2017-11-22T11:59:47.151Z] 11:59:47     INFO - STDOUT:         if response.status != 200:
[task 2017-11-22T11:59:47.152Z] 11:59:47     INFO - STDOUT: >           raise error.from_response(response)
[task 2017-11-22T11:59:47.153Z] 11:59:47     INFO - STDOUT: E           UnknownErrorException: unknown error (500)
[task 2017-11-22T11:59:47.154Z] 11:59:47     INFO - STDOUT: E           
[task 2017-11-22T11:59:47.156Z] 11:59:47     INFO - STDOUT: E           Remote-end stacktrace:
[task 2017-11-22T11:59:47.156Z] 11:59:47     INFO - STDOUT: E           
[task 2017-11-22T11:59:47.157Z] 11:59:47     INFO - STDOUT: E           None
[task 2017-11-22T11:59:47.158Z] 11:59:47     INFO - STDOUT: body       = {'capabilities': {'alwaysMatch': {'moz:firefoxOptions': {'binary': '/builds/worker/workspace/build/application/firefox...web-platform.test,www2.web-platform.test,xn--n8j6ds53lwwkrqhv28a.web-platform.test,xn--lve-6lad.web-platform.test'}}}}}
[task 2017-11-22T11:59:47.158Z] 11:59:47     INFO - STDOUT: method     = 'POST'
[task 2017-11-22T11:59:47.159Z] 11:59:47     INFO - STDOUT: response   = <Response status=500 error=<UnknownErrorException http_status=500>>
[task 2017-11-22T11:59:47.159Z] 11:59:47     INFO - STDOUT: self       = <webdriver.client.Session object at 0x7f7fab7a1490>
[task 2017-11-22T11:59:47.160Z] 11:59:47     INFO - STDOUT: url        = 'session'
[task 2017-11-22T11:59:47.160Z] 11:59:47     INFO - STDOUT: tests/web-platform/tests/tools/webdriver/webdriver/client.py:437: UnknownErrorException
This bug fails most nowaddays but nearly all failures are getting starred against bug 1407383. I would say we dupe it.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1407383
I actually missed to re-enable this test with my patch on bug 1407383. Going to push a try build once bug got merged to mozilla-central.
Assignee: nobody → hskupin
Status: RESOLVED → REOPENED
Depends on: 1407383, 1377805
Keywords: test-disabled
Priority: P5 → P1
Resolution: DUPLICATE → ---
Attachment #8957322 - Flags: review?(mjzffr)
Attachment #8957322 - Flags: review?(james)
Comment on attachment 8957322 [details]
Bug 1420189 - [wdspec] Re-enable test key_shortcuts.py.

https://reviewboard.mozilla.org/r/226220/#review232150
Attachment #8957322 - Flags: review?(mjzffr) → review+
Comment on attachment 8957322 [details]
Bug 1420189 - [wdspec] Re-enable test key_shortcuts.py.

https://reviewboard.mozilla.org/r/226220/#review232164

This is fine but doesn't need two reviewers :)
Attachment #8957322 - Flags: review?(james)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/021837e8787d
[wdspec] Re-enable test key_shortcuts.py. r=maja_zf
https://hg.mozilla.org/mozilla-central/rev/021837e8787d
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.