mail notification system tray icon remains/stays after reading a new message

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Scott.Copus, Assigned: mscott)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

The mail notification system tray icon occasionally remains/stays after reading
a new message.  For example, right now I only have one IMAP account being
checked.  "Inbox" is no longer bold and not showing "Inbox (1)" in bold.  But
the yellow triangle with black exclamation point is still showing--even though I
no longer have "1 new message".

Reproducible: Sometimes
Steps to Reproduce:
I don't know of steps to reproduce.  It doesn't happen all the time.  I haven't
found the pattern yet.

Comment 1

17 years ago
This bug was fixed recently.

Please REOPEN if it still happens in a current build.

pi

*** This bug has been marked as a duplicate of 133130 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
As far as I know, I'm using the latest build, or RC1.  The download page doesn't
include the build number, only "mozilla-win32-1.0rc1-installer.exe".  The mail
notifier icon wouldn't go away for anything in this version, and it only happens
occasionally.  
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
For the latest version use the QA menu and choose "Lates Builds". Your version
is available in Help/About Mozilla.
(Reporter)

Comment 4

17 years ago
Found the reason why the yellow triangle mail notification icon remains on
system tray sometimes.

If you read the e-mail message (message state changes to "read") really quickly
BEFORE the notification icon has a chance to appear on the system tray, the icon
will appear anyway--and remain even though the message is no longer "new".  It
does this because it the order in which the icon is displayed is wrong.  That
system tray icon should be the first thing that is displayed instead of last. 
What happens now is that the new mail sound is played, the sliding new mail
popup appears and slides away (takes time), and THEN the system tray icon
appears.  This delay is what causes the state to become messed up, and causes
that icon to remain on the system tray.

Using Build ID: 2002041711 (RC1)
Scott - try a build of RC3.
Assignee: sspitzer → mscott
Component: Mail Window Front End → Mail Notification
QA Contact: olgam → stephend
(Assignee)

Comment 6

17 years ago
this was fixed after RC1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.