TextEditor::CreateBRImpl() returns wrong offset if it splits a text node

RESOLVED FIXED in Firefox 58

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({regression})

Trunk
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox57 unaffected, firefox58 fixed, firefox59 fixed)

Details

Attachments

(2 attachments)

Comment on attachment 8932023 [details]
Bug 1420415 - TextEditor::CreateBRImpl() needs to make pointToInsertBrNode store mOffset before calling EditorBase::CreateNode()

https://reviewboard.mozilla.org/r/203088/#review208372
Attachment #8932023 - Flags: review?(m_kato) → review+
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/8fc00183c31d
TextEditor::CreateBRImpl() needs to make pointToInsertBrNode store mOffset before calling EditorBase::CreateNode() r=m_kato
https://hg.mozilla.org/mozilla-central/rev/8fc00183c31d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Does this need to be uplifted to Beta or can it ride the 59 train?
Flags: needinfo?(masayuki)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> Does this need to be uplifted to Beta or can it ride the 59 train?

Should be uplifted because it's really simple. But perhaps, I need to create patch for Beta because the code is changed after the last merge. I'll request approval after creating it (or confirming if it's graftable).
Flags: needinfo?(masayuki)
Approval Request Comment
[Feature/Bug causing the regression]:
Regression of bug 1415445.

[User impact if declined]:
*Might* break some web apps with this unexpected behavior change.

[Is this code covered by automated tests?]:
No because I've not found how to hit this behavior change without changing some other code yet.

[Has the fix been verified in Nightly?]:
Yes. I found this bug with fixing another bug which caused new orange. However, this patch fixes the new orange.

[Needs manual test from QE? If yes, steps to reproduce]:
No.

[List of other uplifts needed for the feature/fix]:
No.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
Just making the local variable store offset which will be referred after changing DOM tree before changing the DOM tree.

[String changes made/needed]:
No.
Attachment #8932335 - Flags: approval-mozilla-beta?
Comment on attachment 8932335 [details] [diff] [review]
Patch for beta (just renamed the variable from the patch for m-c)

A low risk fix. Let's take it in Beta58.
Attachment #8932335 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.