FizzillaCFM doesn't handle long file names (> 31 characters)

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
17 years ago
16 years ago

People

(Reporter: dscottbuch, Assigned: ccarlen)

Tracking

({helpwanted, platform-parity, qawanted})

Trunk
Future
PowerPC
macOS
helpwanted, platform-parity, qawanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+)
Gecko/20020501
BuildID:    2002050103

When asked to load

file:///Data/Manuals/PHP_Manual/language.variables.predefined.html

It only gives a listing of the directory (The file does exisit :^)

I made a copy of the file as

file:///Data/Manuals/PHP_Manual/language.variables.pre.html

and it loads perferctly.

Reproducible: Always
Steps to Reproduce:
1. Try loading the long name file : displays directory listing.
2. Try loading the short name file : displays page.
3.

Actual Results:  See Above
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
Last I know of, Moz was still using the old file APIs which are limited to 31 
characters on Mac.  This is probably a dupe.
conrad, any insight?
Keywords: helpwanted
Target Milestone: --- → Future
(Assignee)

Comment 3

17 years ago
It'll be fixed by bug 95481 when we're using HFS+ instead of HFS. Working on it,
but it's a large project.

*** This bug has been marked as a duplicate of 95481 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
I'm reopening and making this dependent on bug 95481, and making this a testcase
for file URLs.
Status: RESOLVED → REOPENED
Depends on: 95481
Resolution: DUPLICATE → ---

Updated

17 years ago
No longer depends on: 95481
(Assignee)

Comment 5

17 years ago
I'll take it then.
Assignee: dougt → ccarlen
Status: REOPENED → NEW
Depends on: 95481

Comment 6

17 years ago
*** Bug 153493 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: pp
Summary: Does not handle long file names → MacOS Xnot handle long file names

Updated

17 years ago
Summary: MacOS Xnot handle long file names → Fizzilla doesn't handle long file names

Updated

17 years ago
Blocks: 161412
This also results in 0-byte files on HTTP uploads. e.g. bugzilla attachments

Comment 8

17 years ago
*** Bug 166151 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Bill: please file a separate bug, put it in whatever component that belongs in
(Forms?) and mark it a DEPENDS of this bug, so it can be tested when this is fixed.

Updated

17 years ago
Blocks: 166151

Comment 10

17 years ago
*** Bug 176705 has been marked as a duplicate of this bug. ***
Augmenting summary to make searches (on '31') easier.
Was: Fizzilla doesn't handle long file names
Now: Fizzilla doesn't handle long file names (> 31 characters)
Summary: Fizzilla doesn't handle long file names → Fizzilla doesn't handle long file names (> 31 characters)
The Mach-0 build of mozilla doesn't have this problem, so none of the pile of
problems this causes. The future is the Mach-0 build.
*** Bug 177480 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 179762 has been marked as a duplicate of this bug. ***

Updated

16 years ago
No longer blocks: 177480

Comment 15

16 years ago
Sorry for the spam. Fizzilla CFM build is dead; should this bug go with it?
Keywords: qawanted

Comment 16

16 years ago
Updated summary to reflect this was a CFM bug and marking WONTFIX since the CFM
build is dead and the Mach-O build doesn't have this problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WONTFIX
Summary: Fizzilla doesn't handle long file names (> 31 characters) → FizzillaCFM doesn't handle long file names (> 31 characters)

Comment 17

16 years ago
VERIFIED/wontfix. CFM RIP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.