Closed Bug 1420461 Opened 2 years ago Closed Last year

Marshal WindowProxy to web window and web frame references

Categories

(Testing :: Marionette, enhancement, P2)

Version 3
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1274251

People

(Reporter: ato, Unassigned)

References

(Blocks 1 open bug)

Details

Marionette needs support for marshaling WindowProxies as web windows
and web frames.
Andreas, this morning I stumbled over https://github.com/w3c/webdriver/pull/1144 and I'm wondering how this is related? Does it mean we do no longer want to return a window or frame at all?
Flags: needinfo?(ato)
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Andreas, this morning I stumbled over
> https://github.com/w3c/webdriver/pull/1144 and I'm wondering how this is
> related? Does it mean we do no longer want to return a window or frame at
> all?

Because no drivers implement web windows or web frames it was removed
from version 1 of the specification, which is the one passing through
the W3C REC track.  If you look at that PR, it was merged into the
level-1 branch, and that web windows and web frames are still a
thing in the Editor’s Draft (ED) on
https://w3c.github.io/webdriver/webdriver-spec.html.

So the conclusion here is that we still want to implement this.
Flags: needinfo?(ato)
Ah, I see. Thanks a lot for clearing that up, and indeed good to hear that.
[Mass Change 2018-01-15] Moving bugs to backlog
Priority: -- → P3
Priority: P3 → P2
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1274251
You need to log in before you can comment on or make changes to this bug.