Regression: After resetting the Theme Settings to Default, the NewTab button keeps placed at the very right side

VERIFIED FIXED in Firefox 58

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: mehmet.sahin, Assigned: Gijs)

Tracking

Trunk
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 fixed, firefox59 verified)

Details

Attachments

(2 attachments)

macOS 10.12.6 - but probably OS=All
59.0a1 (2017-11-25) (64-Bit)

1.) Open the Theme Customizing
2.) Make a change
3.) Reset the settings to Default
4.) Close the Theme Customizing

Actual: The NewTabButton keeps placed at the right side of the Tabbar.

Expected: It should be placed next to the last Tab.

A screencast is attached.

This is a regression.
Here is the regression range:

Good: 2017-11-23-22-01-10

 Bad: 2017-11-24-10-05-00

Maybe https://hg.mozilla.org/mozilla-central/rev/1490a930ccea ?

+Gijs: Can you please take a look?

Thanks.
Flags: needinfo?(gijskruitbosch+bugs)
Blocks: 1418757
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8932103 [details]
Bug 1420583 - fix new tab adjacency logic when using "restore defaults",

https://reviewboard.mozilla.org/r/203148/#review208546
Attachment #8932103 - Flags: review?(jaws) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/08555b236fa7
fix new tab adjacency logic when using "restore defaults", r=jaws
Component: Theme → Tabbed Browser
https://hg.mozilla.org/mozilla-central/rev/08555b236fa7
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Mehmet, can you verify this is now fixed on nightly and/or if you can break where the new tab button shows up some other way? Thanks!
Flags: needinfo?(mehmet.sahin)
(In reply to :Gijs from comment #6)
> Mehmet, can you verify this is now fixed on nightly and/or if you can break
> where the new tab button shows up some other way? Thanks!

Can no longer reproduce it - Looks fixed to me in 59.0a1 (2017-11-28) (64-Bit).

Thank you!
Flags: needinfo?(mehmet.sahin)
Marking verified per comment #7, thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.