Closed Bug 14206 Opened 21 years ago Closed 20 years ago

[Webshell] [top100] Crash-Printing large complex page

Categories

(Core :: Printing: Output, defect, P1, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: teruko, Assigned: rods)

References

()

Details

When you try to print the Latin1 page, Apprunner will crash.

Steps of reproduce
1. Go to above URL
2. Select menu File|Print..
3. Ok to print
Apprunner will crash.

Tested 9-17 Win32 build.

Talkback Incident 13598655
Trigger Type:  Program Crash

 Trigger Reason:  Access violation

 Call Stack:    (Signature = nsWebShell::DoLoadURL 0ade4919)
 nsWebShell::DoLoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 2112]
 nsWebShell::LoadURI
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 2226]
 nsWebShell::LoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 2324]
 nsWebShell::LoadURL
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1933]
 nsGfxTextControlFrame::PostCreateWidget
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp,
line 509]
 nsGfxTextControlFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp,
line 933]
 nsLineLayout::ReflowFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 909]
 nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3378]
 nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3268]
 nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3215]
 nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3164]
 nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2429]
 nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2171]
 nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1417]
 nsAreaFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAreaFrame.cpp, line 412]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsTableCellFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line
604]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsTableRowFrame::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line
1047]
 nsTableRowFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line
1454]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsTableRowGroupFrame::ReflowMappedChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 451]
 nsTableRowGroupFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 1037]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsTableFrame::ResizeReflowPass1
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2361]
 nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2222]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsTableOuterFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
910]
 nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp,
line 230]
 nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2952]
 nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2381]
 nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2171]
 nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1417]
 nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp,
line 230]
 nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2952]
 nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2381]
 nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2171]
 nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1417]
 nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp,
line 230]
 nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2952]
 nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2381]
 nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2171]
 nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1417]
 nsAreaFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsAreaFrame.cpp, line 412]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsPageFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPageFrame.cpp, line 126]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 nsSimplePageSequenceFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsSimplePageSequence.cpp,
line 243]
 nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
462]
 ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line
516]
 PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 872]
 DocumentViewerImpl::Print
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocumentViewer.cpp, line 611]
 nsBrowserInstance::Print
[d:\builds\seamonkey\mozilla\xpfe\browser\src\nsBrowserInstance.cpp, line 1838]
 XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 135]
 nsXPCWrappedNativeClass::CallWrappedMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativeclass.cpp,
line 662]
 WrappedNative_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 171]
 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 655]
 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2229]
 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 675]
 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2229]
 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 675]
 js_InternalCall
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 748]
 JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2664]
 nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 112]
Priority: P3 → P1
This happens in Linux build.
Component: Internationalization → Printing
QA Contact: teruko
Summary: Crash-Printing Latin1 page → Crash-Printing large complex page
This also happens on english systems with larger files
Assignee: ftang → slamm
Assignee: slamm → chofmann
Not sure why this was passed to me. Passing up to chofmann.
Assignee: chofmann → don
Summary: Crash-Printing large complex page → [WebShell][top100] Crash-Printing large complex page
oh,  webshell on the stack. that makes assignment easy. -> don, er,
travis, er, rpotts... ;-)

is this an easy one to get?
Look like we land in this code...

2098 radha     1.114  /* WebShell was primarily passing the buck when it came to
streamObserver.
2099                   * So, pass on the observer which is already a
streamObserver to DocLoder.
2100                   *  - Radha
2101                   */
2102 brendan   1.234
2103 mscott    1.235   return mDocLoader->LoadDocument(aUri,        // URL
string
2104 mcafee    1.198                                   aCommand,        //
Command
2105                                                   this,            //
Container
2106                                                   aPostDataStream, // Post
Data
2107                                                   nsnull,          // Extra
Info...
2108                                                   mObserver,       //
Observer
2109                                                   aType,           //
reload type
2110 vidur     1.248                                   aLocalIP,        // load
attributes.
2111                                                   aReferrer);      //
referrer
2112 troy      1.100 }
Add vidur to the list since he change a lot of webshell code
recently including all the nsWebShell.cpp line list in this bug
report- [nsWebShell.cpp line 1933, 2324, 2225, 2110]
Should we reassign this to vidur ?
*** Bug 13947 has been marked as a duplicate of this bug. ***
Blocks: 14356
Assignee: don → scc
Severity: blocker → critical
Downgrading from blocker to critical and re-assinging to scc for now per
agreement with chofmann.

PLEASE NOTE: The XPApps team does not own the webshell.  Not yet anyway.
Status: NEW → ASSIGNED
I saw this last night when I was getting printing working - again :-)

It looks like we crash whenever we try to print a document containing a form
with an Edit field...

For some reason, the docloader assoiciated with the edit-field webshell is null.
So, it crashes when it tries to load about:blank
Summary: [WebShell][top100] Crash-Printing large complex page → [Webshell] [top100] Crash-Printing large complex page
(Mass-) Re-assigning [Webshell] bugs to travis, on the advice of dp, et al.  Many
of these may be invalid in the new world of the re-written webshell, but he
certainly needs to be aware of these issues.  Hope this helps you, travis.
Target Milestone: M12
Move to M12 for now.

Travis, is this still a bug?  Is it even our bug?
Status: NEW → ASSIGNED
Not sure, but I'm pretty sure this will go away when either the WebShell
redesign or the URILoader lands.  So, I'll accept it and mark it as fixed when
URI loading lands.
QA Contact: shrir
Setting QA Contact.
Assignee: travis → mscott
Status: ASSIGNED → NEW
Reassigning to you mscott as this should go away when we clean out the webshell
loadURL stuff.
Target Milestone: M12 → M13
Moving all my non dogfood / PDT stopper bugs to M13.Moving all my non dogfood /
PDT stopper bugs to M13.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This page prints with today's windows commercial build (1999122023) without a
crash.Marking as fixed.
Status: RESOLVED → VERIFIED
Verified with Windows commercial build 1999122023
printing is very platform dependent.  You probably shouldn't mark this as
verified until all platforms have been tested.
Status: VERIFIED → REOPENED
Reopening... !! Thanks steve !
Clearing FIXED resolution due to reopen.
Resolution: FIXED → ---
I see lots of asserts in table code printing this page on windows today.
Debug build, code from 12/21/99 late afternoon PST.
Using the debugger to continue through the asserts, a single blank page prints
and the app seems hung.
cc'ing chris because of the asserts in table layout.
Assignee: mscott → dcone
Status: REOPENED → NEW
I'm not seeing any crashes in the doc loader anymore.
Like buster, I see lots of asserts down in nsImageWin.

Here's a small stack trace:
nsDebug::Assertion(const char * 0x003e4cc4, const char * 0x003e4cb8, const char
* 0x003e4c88, int 773) line 186 + 13 bytes
BuildDIB(tagBITMAPINFOHEADER * *
0x028c3534, int 14, int 16, int 32, char * 0x028c34f8) line 773 + 35 bytes
nsImageWin::ConvertDDBtoDIB(int 14, int 16) line 737 + 48 bytes
nsImageWin::PrintDDB(void * 0x06c23540, int 94, int 2964, int 14, int 16) line
699
nsImageWin::Draw(nsImageWin * const 0x028c34f0, nsIRenderingContext & {...},
void * 0x06c23540, int 94, int 2964, int 14, int 16) line 555
nsRenderingContextWin::DrawImage(nsRenderingContextWin * const 0x06c24d40,
nsIImage * 0x028c34f0, const nsRect & {x=105 y=105 width=34 height=38}) line
2166
nsRenderingContextWin::DrawImage(nsRenderingContextWin * const 0x06c24d40,
nsIImage * 0x028c34f0, int 105, int 105, int 34, int 38) line 2143
nsRenderingContextWin::DrawImage(nsRenderingContextWin * const 0x06c24d40,
nsIImage * 0x028c34f0, int 105, int 105) line 2130
nsImageFrame::DisplayAltFeedback(nsIPresContext * 0x05bfc860,
nsIRenderingContext & {...}, int 0) line 458
nsImageFrame::Paint(nsImageFrame *
const 0x04bab9f8, nsIPresContext * 0x05bfc860, nsIRenderingContext & {...},
const nsRect & {x=0 y=0 width=1650 height=750}, nsFramePaintLayer
eFramePaintLayer_Underlay) line 507
nsContainerFrame::PaintChild(nsIPresContext
* 0x05bfc860, nsIRenderingContext & {...}, const nsRect & {x=0 y=-750 width=1950
height=808}, nsIFrame * 0x04bab9f8, nsFramePaintLayer eFramePaintLayer_Underlay)
line 221
nsContainerFrame::PaintChildren(nsIPresContext * 0x05bfc860,
nsIRenderingContext & {...}, const nsRect & {x=0 y=-750 width=1950 height=808},
nsFramePaintLayer eFramePaintLayer_Underlay) line 160
nsHTMLContainerFrame::Paint(nsHTMLContainerFrame * const 0x04bab9c0,
nsIPresContext * 0x05bfc860, nsIRenderingContext & {...}, const nsRect & {x=0
y=-750 width=1950 height=808}, nsFramePaintLayer eFramePaintLayer_Underlay) line
89
nsContainerFrame::PaintChild(nsIPresContext * 0x05bfc860, nsIRenderingContext
& {...}, const nsRect & {x=0 y=0 width=1950 height=808}, nsIFrame * 0x04bab9c0,
nsFramePaintLayer eFramePaintLayer_Underlay) line 221
nsBlockFrame::PaintChildren(nsIPresContext * 0x05bfc860, nsIRenderingContext &
{...}, const nsRect & {x=0 y=0 width=1950 height=808}, nsFramePaintLayer
eFramePaintLayer_Underlay) line 5803
nsBlockFrame::Paint(nsBlockFrame * const
0x04bab93c, nsIPresContext * 0x05bfc860, nsIRenderingContext & {...}, const
nsRect & {x=0 y=0 width=1950 height=808}, nsFramePaintLayer
eFramePaintLayer_Underlay) line 5681
nsContainerFrame::PaintChild(nsIPresContext
* 0x05bfc860, nsIRenderingContext & {...}, const nsRect & {x=0 y=0 width=1950
height=7817}, nsIFrame * 0x04bab93c, nsFramePaintLayer
eFramePaintLayer_Underlay) line 221
n

The assertion is complaining about an unexpected image depth.

After skipping past the assertions, the correct document prints!!!. I'm not
freezing the app like buster mentioned either.

doesn't appear to be any problems with uri loading here. I'm going to re-assign
to someone in layout who would know more about printing. dcone?
Status: NEW → ASSIGNED
Assignee: dcone → karnaze
Status: ASSIGNED → NEW
I am getting and assertion in nsCellMap.  This is table stuff, Chris Karnaze may
know more about.  I did fix some assertions that were being hit previously, now
they are hitting the table code.
Assignee: karnaze → rods
The table assertions have been fixed. mDisplayContent is null. Reassigning to
Rod.

nsComboboxControlFrame::InitTextStr(nsIPresContext * 0x021e08f0, int 0) line 227
+ 38 bytes
nsComboboxControlFrame::SetInitialChildList(nsComboboxControlFrame * const
0x00d830d8, nsIPresContext * 0x021e08f0, nsIAtom * 0x00000000 {???}, nsIFrame *
0x00000000) line 1429
nsCSSFrameConstructor::ConstructSelectFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x0220a250, nsIFrame * 0x00d82ee8, nsIAtom * 0x01294a40 {"select"},
nsIStyleContext * 0x02559c90, nsIFrame * & 0x00000000, int & 0, int 0, int & 0,
int 0, nsFrameItems & {...}) line 3025
nsCSSFrameConstructor::ConstructFrameByTag(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x0220a250, nsIFrame * 0x00d82ee8, nsIAtom * 0x01294a40 {"select"},
nsIStyleContext * 0x02559c90, nsFrameItems & {...}) line 3558 + 60 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x0220a250, nsIFrame
* 0x00d82ee8, nsFrameItems & {...}) line 5416 + 50 bytes
nsCSSFrameConstructor::ProcessChildren(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x0220ac90, nsIFrame
* 0x00d82ee8, int 1, nsFrameItems & {...}, int 0) line 8646 + 37 bytes
nsCSSFrameConstructor::ConstructFrameByTag(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x0220ac90, nsIFrame * 0x00d82ea0, nsIAtom * 0x012868f0 {"form"},
nsIStyleContext * 0x025570a0, nsFrameItems & {...}) line 3659 + 36 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x0220ac90, nsIFrame
* 0x00d82ea0, nsFrameItems & {...}) line 5416 + 50 bytes
nsCSSFrameConstructor::ProcessBlockChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x0220ad1c, nsIFrame * 0x00d82ea0, int 1, nsFrameItems & {...}, int 1) line 9866
+ 37 bytes
nsCSSFrameConstructor::ConstructBlock(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, const nsStyleDisplay *
0x02557760, nsIContent * 0x0220ad1c, nsIFrame * 0x00d82e1c, nsIStyleContext *
0x02557530, nsIFrame * 0x00d82ea0) line 9819 + 36 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02557760, nsIContent * 0x0220ad1c, nsIFrame * 0x00d82e1c,
nsIStyleContext * 0x02557530, nsFrameItems & {...}) line 4906 + 43 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x0220ad1c, nsIFrame
* 0x00d82e1c, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::ProcessChildren(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01cd0eb0, nsIFrame
* 0x00d82e1c, int 1, nsFrameItems & {...}, int 1) line 8646 + 37 bytes
nsCSSFrameConstructor::ConstructTableCellFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0eb0, nsIFrame * 0x0231d7dc, nsIStyleContext * 0x02556970, nsIFrame * &
0x00d82dc0, nsIFrame * & 0x00d82e1c, nsTableCreator & {...}, int 1) line 1838 +
38 bytes
nsCSSFrameConstructor::ConstructTableCellFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0eb0, nsIFrame * 0x0231d7dc, nsIStyleContext * 0x02556970, nsIFrame * &
0x00000000, nsIFrame * & 0x00d82dc0, nsIFrame * & 0x00d82e1c, nsTableCreator &
{...}, int 1) line 1753 + 53 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02556ba0, nsIContent * 0x01cd0eb0, nsIFrame * 0x0231d7dc,
nsIStyleContext * 0x02556970, nsFrameItems & {...}) line 4991 + 59 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01cd0eb0, nsIFrame
* 0x0231d7dc, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::TableProcessChild(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0eb0, nsIFrame * 0x0231d7dc, nsIStyleContext * 0x02556cf0, nsFrameItems &
{...}, nsTableCreator & {...}) line 1920 + 32 bytes
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0f2c, nsIFrame * 0x0231d7dc, nsFrameItems & {...}, nsTableCreator & {...})
line 1894 + 50 bytes
nsCSSFrameConstructor::ConstructTableRowFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0f2c, nsIFrame * 0x0231d79c, nsIStyleContext * 0x02556cf0, int 1, nsIFrame
* & 0x0231d7dc, nsTableCreator & {...}) line 1640 + 38 bytes
nsCSSFrameConstructor::ConstructTableRowFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0f2c, nsIFrame * 0x0231d79c, nsIStyleContext * 0x02556cf0, nsIFrame * &
0x00000000, nsIFrame * & 0x0231d7dc, nsTableCreator & {...}, nsTableList *
0x00000000) line 1578 + 49 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02556f20, nsIContent * 0x01cd0f2c, nsIFrame * 0x0231d79c,
nsIStyleContext * 0x02556cf0, nsFrameItems & {...}) line 4983 + 52 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01cd0f2c, nsIFrame
* 0x0231d79c, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::TableProcessChild(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0f2c, nsIFrame * 0x0231d79c, nsIStyleContext * 0x02555340, nsFrameItems &
{...}, nsTableCreator & {...}) line 1920 + 32 bytes
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0fac, nsIFrame * 0x0231d79c, nsFrameItems & {...}, nsTableCreator & {...})
line 1894 + 50 bytes
nsCSSFrameConstructor::ConstructTableGroupFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0fac, nsIFrame * 0x0231d730, nsIStyleContext * 0x02555340, int 1, nsIFrame
* & 0x0231d79c, nsIFrame * & 0x0231d79c, nsTableCreator & {...}, int 1) line
1524
nsCSSFrameConstructor::ConstructTableGroupFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01cd0fac, nsIFrame * 0x0231d730, nsIStyleContext * 0x02555340, int 1, nsIFrame
* & 0x0231d79c, nsIFrame * & 0x0231d79c, nsTableCreator & {...}, nsTableList *
0x00000000) line 1422 + 57 bytes
nsCSSFrameConstructor::ConstructTableFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c9f1fc, nsIFrame * 0x0231d658, nsIStyleContext * 0x02555860, nsIFrame * &
0x0231d6dc, nsTableCreator & {...}) line 1120 + 60 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02555a90, nsIContent * 0x01c9f1fc, nsIFrame * 0x0231d658,
nsIStyleContext * 0x02555860, nsFrameItems & {...}) line 4947 + 46 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01c9f1fc, nsIFrame
* 0x0231d658, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::ProcessChildren(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01ccf3d0, nsIFrame
* 0x0231d658, int 1, nsFrameItems & {...}, int 1) line 8646 + 37 bytes
nsCSSFrameConstructor::ConstructTableCellFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01ccf3d0, nsIFrame * 0x00db2368, nsIStyleContext * 0x02554c40, nsIFrame * &
0x0231d5fc, nsIFrame * & 0x0231d658, nsTableCreator & {...}, int 1) line 1838 +
38 bytes
nsCSSFrameConstructor::ConstructTableCellFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01ccf3d0, nsIFrame * 0x00db2368, nsIStyleContext * 0x02554c40, nsIFrame * &
0x00000000, nsIFrame * & 0x0231d5fc, nsIFrame * & 0x0231d658, nsTableCreator &
{...}, int 1) line 1753 + 53 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02554e70, nsIContent * 0x01ccf3d0, nsIFrame * 0x00db2368,
nsIStyleContext * 0x02554c40, nsFrameItems & {...}) line 4991 + 59 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01ccf3d0, nsIFrame
* 0x00db2368, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::TableProcessChild(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01ccf3d0, nsIFrame * 0x00db2368, nsIStyleContext * 0x0259a3e0, nsFrameItems &
{...}, nsTableCreator & {...}) line 1920 + 32 bytes
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c0c, nsIFrame * 0x00db2368, nsFrameItems & {...}, nsTableCreator & {...})
line 1894 + 50 bytes
nsCSSFrameConstructor::ConstructTableRowFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c0c, nsIFrame * 0x00db2328, nsIStyleContext * 0x0259a3e0, int 1, nsIFrame
* & 0x00db2368, nsTableCreator & {...}) line 1640 + 38 bytes
nsCSSFrameConstructor::ConstructTableRowFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c0c, nsIFrame * 0x00db2328, nsIStyleContext * 0x0259a3e0, nsIFrame * &
0x00000000, nsIFrame * & 0x00db2368, nsTableCreator & {...}, nsTableList *
0x00000000) line 1578 + 49 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x0259a610, nsIContent * 0x01c46c0c, nsIFrame * 0x00db2328,
nsIStyleContext * 0x0259a3e0, nsFrameItems & {...}) line 4983 + 52 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01c46c0c, nsIFrame
* 0x00db2328, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::TableProcessChild(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c0c, nsIFrame * 0x00db2328, nsIStyleContext * 0x0259a8c0, nsFrameItems &
{...}, nsTableCreator & {...}) line 1920 + 32 bytes
nsCSSFrameConstructor::TableProcessChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c8c, nsIFrame * 0x00db2328, nsFrameItems & {...}, nsTableCreator & {...})
line 1894 + 50 bytes
nsCSSFrameConstructor::ConstructTableGroupFrameOnly(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c8c, nsIFrame * 0x00db22bc, nsIStyleContext * 0x0259a8c0, int 1, nsIFrame
* & 0x00db2328, nsIFrame * & 0x00db2328, nsTableCreator & {...}, int 1) line
1524
nsCSSFrameConstructor::ConstructTableGroupFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c46c8c, nsIFrame * 0x00db22bc, nsIStyleContext * 0x0259a8c0, int 1, nsIFrame
* & 0x00db2328, nsIFrame * & 0x00db2328, nsTableCreator & {...}, nsTableList *
0x00000000) line 1422 + 57 bytes
nsCSSFrameConstructor::ConstructTableFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c450bc, nsIFrame * 0x00db2170, nsIStyleContext * 0x0259acf0, nsIFrame * &
0x00db2268, nsTableCreator & {...}) line 1120 + 60 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x0259af20, nsIContent * 0x01c450bc, nsIFrame * 0x00db2170,
nsIStyleContext * 0x0259acf0, nsFrameItems & {...}) line 4947 + 46 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01c450bc, nsIFrame
* 0x00db2170, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::ProcessBlockChildren(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01263acc, nsIFrame * 0x00db2170, int 1, nsFrameItems & {...}, int 1) line 9866
+ 37 bytes
nsCSSFrameConstructor::ConstructBlock(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, const nsStyleDisplay *
0x02598bf0, nsIContent * 0x01263acc, nsIFrame * 0x00db20e8, nsIStyleContext *
0x025989c0, nsIFrame * 0x00db2170) line 9819 + 36 bytes
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, const
nsStyleDisplay * 0x02598bf0, nsIContent * 0x01263acc, nsIFrame * 0x00db20e8,
nsIStyleContext * 0x025989c0, nsFrameItems & {...}) line 4906 + 43 bytes
nsCSSFrameConstructor::ConstructFrame(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01263acc, nsIFrame
* 0x00db20e8, nsFrameItems & {...}) line 5447 + 45 bytes
nsCSSFrameConstructor::ProcessChildren(nsIPresShell * 0x021e2570, nsIPresContext
* 0x021e08f0, nsFrameConstructorState & {...}, nsIContent * 0x01c6e48c, nsIFrame
* 0x00db20e8, int 1, nsFrameItems & {...}, int 1) line 8646 + 37 bytes
nsCSSFrameConstructor::ConstructDocElementFrame(nsIPresShell * 0x021e2570,
nsIPresContext * 0x021e08f0, nsFrameConstructorState & {...}, nsIContent *
0x01c6e48c, nsIFrame * 0x00db20b0, nsIStyleContext * 0x0259f120, nsIFrame * &
0x00db20e8) line 2333
nsCSSFrameConstructor::ContentInserted(nsCSSFrameConstructor * const 0x021e2120,
nsIPresContext * 0x021e08f0, nsIContent * 0x00000000, nsIContent * 0x01c6e48c,
int 0, nsILayoutHistoryState * 0x00000000) line 6298
StyleSetImpl::ContentInserted(StyleSetImpl * const 0x021e6be0, nsIPresContext *
0x021e08f0, nsIContent * 0x00000000, nsIContent * 0x01c6e48c, int 0) line 948
PresShell::InitialReflow(PresShell * const 0x021e2570, int 11520, int 15206)
line 1090
DocumentViewerImpl::Print(DocumentViewerImpl * const 0x01c63708) line 1157
nsBrowserWindow::DoPrint() line 2426
nsBrowserWindow::DispatchMenuItem(int 40060) line 623
nsNativeBrowserWindow::DispatchMenuItem(int 40060) line 125
HandleBrowserEvent(nsGUIEvent * 0x0012fe38) line 346 + 21 bytes
nsWindow::DispatchEvent(nsWindow * const 0x0125d684, nsGUIEvent * 0x0012fe38,
nsEventStatus & nsEventStatus_eIgnore) line 502 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fe38) line 523
nsWindow::ProcessMessage(unsigned int 273, unsigned int 40060, long 0, long *
0x0012fee4) line 2535 + 21 bytes
nsWindow::WindowProc(HWND__ * 0x00c4059c, unsigned int 273, unsigned int 40060,
long 0) line 689 + 27 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsNativeViewerApp::Run() line 76
main(int 1, char * * 0x00be1870) line 137 + 11 bytes
mainCRTStartup() line 338 + 17 bytes
Target Milestone: M13 → M14
works in my tree, this is not critical, moving to M14
retested on chris's machine and it prit fne with the current build. marking
fixed
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Oops, forgot to mark it fixed.
Status: RESOLVED → VERIFIED
Page prints fine on windows NT using commercial build (2000011908), MAC
commercial build(2000011910) and Linux commercial build (2000011908). Marking
verified.
You need to log in before you can comment on or make changes to this bug.