Permanent failure in /webrtc/RTCDTMFSender-ontonechange-long.https.html caused by bug 1493012

REOPENED
Assigned to

Status

defect
P5
normal
REOPENED
2 years ago
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

Tracking

(Depends on 1 bug, {regression})

Trunk
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Reporter

Description

2 years ago
treeherder
Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=147621393&repo=mozilla-central

https://queue.taskcluster.net/v1/task/UMKUbT7fThajSVTYQxvYrQ/runs/0/artifacts/public/logs/live_backing.log

[task 2017-11-25T20:37:03.832Z] 20:37:03     INFO - TEST-UNEXPECTED-FAIL | /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approximately after 6070 milliseconds expected 6070 +/- 250 but got 6610
[task 2017-11-25T20:37:03.832Z] 20:37:03     INFO - test_tone_change_events/</</onToneChange<@https://web-platform.test:8443/webrtc/RTCDTMFSender-helper.js:79:9
[task 2017-11-25T20:37:03.833Z] 20:37:03     INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1489:20
[task 2017-11-25T20:37:03.833Z] 20:37:03     INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1513:20
[task 2017-11-25T20:37:03.833Z] 20:37:03     INFO - TEST-OK | /webrtc/RTCDTMFSender-ontonechange-long.https.html | took 7407ms
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Component: web-platform-tests → WebRTC
Product: Testing → Core
Version: Version 3 → Trunk
Comment hidden (Intermittent Failures Robot)
Reporter

Updated

a year ago
See Also: → 1460469
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1460165
Duplicate of this bug: 1460469
Summary: Intermittent /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approx after 6070 milliseconds expected 6070 +/- 250 → Intermittent /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approx after 6070 milliseconds expected
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Comment 35

7 months ago
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/373da42b11e7
Disable WebRTC test for instability, a=testonly
FYI.   Seems odd this was disabled without discussion
Flags: needinfo?(drno)
Well, that would be something entirely different than an intermittent failure, wouldn't it?
Blocks: 1493012
No longer blocks: stylo-intermittent-test-failures
Component: WebRTC → web-platform-tests
Product: Core → Testing
Summary: Intermittent /webrtc/RTCDTMFSender-ontonechange-long.https.html | insertDTMF with duration greater than 6000 should be clamped to 6000 - assert_approx_equals: Expect tonechange event for "" to be fired approx after 6070 milliseconds expected → Permanent failure in /webrtc/RTCDTMFSender-ontonechange-long.https.html caused by bug 1493012
Well, I did another check and it was frequently failing and jgraham decided to disable those tests. 
Failed also for wpt10: https://treeherder.mozilla.org/logviewer.html#?job_id=206150023&repo=mozilla-inbound&lineNumber=10116 

Wr2 failures: https://treeherder.mozilla.org/logviewer.html#?job_id=206148410&repo=mozilla-inbound&lineNumber=2666

The disable push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=bc1992018c602430c33ab99d3004d787a2fa07bd&group_state=expanded

jgraham> RaulGurzau|sheriffduty: Looks like intermittents. This ontonechange test is clearly really intermittent and the overflow-scroll one looks like it probably has a couple of pixels of fuzz for some reason
7:54 PM R<RaulGurzau|sheriffduty> jgraham: then will file bugs for them, thank you
8:02 PM J<jgraham> RaulGurzau: Pushed some changes to disable those tests

Comment 40

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/373da42b11e7
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Assignee: nobody → james
That would have been funnier with it still described as an intermittent.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Intermittent Failures Robot)
Looks like bug 1498538 is where the problem is discussed.
Depends on: 1498538
Flags: needinfo?(drno)
You need to log in before you can comment on or make changes to this bug.