Intermittent toolkit/mozapps/extensions/test/xpinstall/browser_navigateaway3.js Automation Error: mozprocess timed out after 1000 seconds running ['/builds/worker/workspace/build/venv/bin/python', '-u' '/worker/workspace/build/tests/mochitest/runtests.py

RESOLVED DUPLICATE of bug 1198261

Status

()

Toolkit
Add-ons Manager
P5
normal
RESOLVED DUPLICATE of bug 1198261
2 months ago
2 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
treeherder
Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=147628137&repo=mozilla-central

https://queue.taskcluster.net/v1/task/bqMd9ijMRJ6wzbQC04_8_Q/runs/0/artifacts/public/logs/live_backing.log

[task 2017-11-25T22:42:41.869Z] 22:42:41     INFO - TEST-START | toolkit/mozapps/extensions/test/xpinstall/browser_navigateaway3.js
[task 2017-11-25T22:42:41.946Z] 22:42:41     INFO - GECKO(4627) | Sending InstallTriggered
[task 2017-11-25T22:42:41.982Z] 22:42:41     INFO - GECKO(4627) | 1511649761979	addons.xpi	DEBUG	Download started for http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/amosigned.xpi to file /tmp/tmp-644.xpi
[task 2017-11-25T22:42:41.984Z] 22:42:41     INFO - GECKO(4627) | 1511649761982	addons.xpi	DEBUG	Download of http://example.com/browser/toolkit/mozapps/extensions/test/xpinstall/amosigned.xpi completed.
[task 2017-11-25T22:42:42.020Z] 22:42:42     INFO - GECKO(4627) | 1511649762018	addons.repository	DEBUG	cacheAddons: enabled false IDs ["unsigned-xpi@tests.mozilla.org"]
[task 2017-11-25T22:42:42.041Z] 22:42:42     INFO - GECKO(4627) | Sending PageLoaded
[task 2017-11-25T22:49:22.219Z] 22:49:22     INFO - GECKO(4627) | 1511650162213	addons.manager	INFO	Skipping background update check
[task 2017-11-25T22:51:22.225Z] 22:51:22     INFO - GECKO(4627) | *** Blocklist::notify: Requesting http://127.0.0.1:8888/extensions-dummy/blocklistURL
[task 2017-11-25T22:51:22.242Z] 22:51:22     INFO - GECKO(4627) | *** Blocklist::onXMLLoad: there was an error during load
[task 2017-11-25T23:08:02.272Z] 23:08:02     INFO - Automation Error: mozprocess timed out after 1000 seconds running ['/builds/worker/workspace/build/venv/bin/python', '-u', '/builds/worker/workspace/build/tests/mochitest/runtests.py', '--disable-e10s', '--total-chunks', '7', '--this-chunk', '5', '--jscov-dir-prefix=/builds/worker/workspace/build/blobber_upload_dir', '--appname=/builds/worker/workspace/build/application/firefox/firefox', '--utility-path=tests/bin', '--extra-profile-file=tests/bin/plugins', '--symbols-path=https://queue.taskcluster.net/v1/task/KVdbRoDQQhCezgCXrjkenw/artifacts/public/build/target.crashreporter-symbols.zip', '--certificate-path=tests/certs', '--setpref=webgl.force-enabled=true', '--quiet', '--log-raw=/builds/worker/workspace/build/blobber_upload_dir/browser-chrome-coverage_raw.log', '--log-errorsummary=/builds/worker/workspace/build/blobber_upload_dir/browser-chrome-coverage_errorsummary.log', '--use-test-media-devices', '--screenshot-on-fail', '--cleanup-crashes', '--marionette-startup-timeout=180', '--sandbox-read-whitelist=/builds/worker/workspace/build', '--log-raw=-', '--flavor=browser', '--chunk-by-runtime', '--timeout=1200']
[task 2017-11-25T23:08:02.313Z] 23:08:02    ERROR - timed out after 1000 seconds of no output
[task 2017-11-25T23:08:02.317Z] 23:08:02    ERROR - Return code: -15
[task 2017-11-25T23:08:02.317Z] 23:08:02    ERROR - No suite end message was emitted by this harness.
[task 2017-11-25T23:08:02.317Z] 23:08:02     INFO - TinderboxPrint: mochitest-browser-chrome-coverage<br/>219/0/0
[task 2017-11-25T23:08:02.317Z] 23:08:02    ERROR - # TBPL FAILURE #
[task 2017-11-25T23:08:02.317Z] 23:08:02  WARNING - setting return code to 2
[task 2017-11-25T23:08:02.317Z] 23:08:02    ERROR - The mochitest suite: browser-chrome-coverage ran with return status: FAILURE
[task 2017-11-25T23:08:02.317Z] 23:08:02     INFO - Running post-action listener: _package_coverage_data
[task 2017-11-25T23:08:02.317Z] 23:08:02     INFO - Beginning compression of JSDCov artifacts...
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1418227
Sorry, but this is not a dupe. There is something else going on here. Maybe the issue we have with mozprocess and not shutting down content processes. Geoff should be able to give more details.
Status: RESOLVED → REOPENED
Flags: needinfo?(gbrown)
Resolution: DUPLICATE → ---
Well there's nothing useful in here to go on to troubleshoot the problem.  If you think there's some hope of figuring out what's going on, feel free to re-open but please move to a different component.
Status: REOPENED → RESOLVED
Last Resolved: 2 months ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1198261

Comment 4

2 months ago
2 failures in 744 pushes (0.003 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-central: 2

Platform breakdown:
* linux64-jsdcov: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1420644&startday=2017-11-20&endday=2017-11-26&tree=all

Comment 5

2 months ago
(In reply to Henrik Skupin (:whimboo) from comment #2)
> Sorry, but this is not a dupe. There is something else going on here. Maybe
> the issue we have with mozprocess and not shutting down content processes.
> Geoff should be able to give more details.

It seems unexpected that we didn't hit a harness timeout here; I can't say with certainty why that is.

I notice that all failures reported here are on linux64-jsdcov, like bug 1418553...maybe something related to code coverage.
Flags: needinfo?(gbrown)
See Also: → bug 1418553
You need to log in before you can comment on or make changes to this bug.