Closed Bug 1420708 Opened 3 years ago Closed 3 years ago

The Data Manager can not be closed with the standard close command key (Ctrl-W)

Categories

(SeaMonkey :: Passwords & Permissions, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.49esr fixed, seamonkey2.53+ fixed, seamonkey2.54 wontfix, seamonkey2.55 fixed, seamonkey2.56 fixed)

RESOLVED FIXED
seamonkey2.56
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 + fixed
seamonkey2.54 --- wontfix
seamonkey2.55 --- fixed
seamonkey2.56 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

On Windows only Alt-F4 closes the Data Manager Window. Same on Linux.
Dedicated to the complainers on irc :)
Attachment #8931932 - Flags: review?(iann_bugzilla)
Summary: The Data Manager can not be closed with the normal close command key (Ctrl-W). → The Data Manager can not be closed with the standard close command key (Ctrl-W)
Comment on attachment 8931932 [details] [diff] [review]
1420708-DataManagerClose.patch

LGTM r=me
Attachment #8931932 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/ec11eac01617
Allow the Data Manager Window to be closed with the standard command key (Ctrl-W). r=IanN
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Seamonkey2.56
Comment on attachment 8931932 [details] [diff] [review]
1420708-DataManagerClose.patch

[Approval Request Comment]
Regression caused by (bug #): -- 
User impact if declined: standard shortcut for closing windows does not work here.
Testing completed (on m-c, etc.): c-r
Risk to taking this patch (and alternatives if risky): none trivial enhancement.
String changes made by this patch: -- (an existing value is used).
Attachment #8931932 - Flags: approval-comm-esr52?
Attachment #8931932 - Flags: approval-comm-beta?
Comment on attachment 8931932 [details] [diff] [review]
1420708-DataManagerClose.patch

a=me
Attachment #8931932 - Flags: approval-comm-esr52?
Attachment #8931932 - Flags: approval-comm-esr52+
Attachment #8931932 - Flags: approval-comm-beta?
Attachment #8931932 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.