Closed Bug 1420717 Opened 3 years ago Closed 3 years ago

Restore about: page for SeaMonkey after Bug 1408044 removed it from Gecko.

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.56 fixed)

RESOLVED FIXED
seamonkey2.56
Tracking Status
seamonkey2.56 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file, 2 obsolete files)

Bug 1408044 removed about: because no one used it any more. 

Oh wait we do, so Help->About SeaMonkey is now broken and needs to be fixed.
Attached patch 1420717-restore-about.patch (obsolete) — Splinter Review
Got a patch for Bill. Will check it out and set r? if ok. We are not sure if this works in all cases with the removed aboutredirector support. Might be needed to be switched to about:seamonkey or another about:xxxxx
Comment on attachment 8931954 [details] [diff] [review]
1420717-restore-about.patch

Seems to work fine. If there are issues I will relay them to Bill.
Attachment #8931954 - Flags: review?(iann_bugzilla)
Attached patch 1420717-restore-about.patch (obsolete) — Splinter Review
I talked with Bill and we both thought that putting an l10n note in would help localizers finding the old content for reuse.
Attachment #8931954 - Attachment is obsolete: true
Attachment #8931954 - Flags: review?(iann_bugzilla)
Attachment #8933812 - Flags: review?(iann_bugzilla)
Comment on attachment 8933812 [details] [diff] [review]
1420717-restore-about.patch

r=me if you fix the added "<!-- LOCALIZATION NOTE ... " to honor 80 char widths (like the existing ones).
Attachment #8933812 - Flags: review+
Duplicate of this bug: 1419449
Comments reformatted. r+ from stefanh carried forward.

I added an lf for the the added block comment. I think it looks better now. If not I can push a whitespace only followup patch.
Attachment #8933812 - Attachment is obsolete: true
Attachment #8933812 - Flags: review?(iann_bugzilla)
Attachment #8936077 - Flags: review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/1420d31fa671
Restore 'about:' URL functionaliity removed by bug 1408044. r=stefanh
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Thanks Bill.
Target Milestone: --- → Seamonkey2.56
You need to log in before you can comment on or make changes to this bug.