Java applet opens in a very small window

RESOLVED DUPLICATE of bug 161139

Status

Core Graveyard
Java: OJI
--
major
RESOLVED DUPLICATE of bug 161139
16 years ago
7 years ago

People

(Reporter: Ajay Gautam, Assigned: Joe Chou)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020418
BuildID:    2002041803

Hello

The java applet on the above mentioned page opens in a very small window. For
IE, it opens in a regular window.

You might need to join this group to see this problem. Or if you are a member of
"any" yahoo group, pls visit the Chat page of that group.

Would really appreciate a fix / work around. Our group has a weekly online study
chat (wednesday).

Thanks

Ajay Gautam

Reproducible: Always
Steps to Reproduce:
1. Goto above page or to any yahoo group's chat page


Actual Results:  Same as description

Expected Results:  The chat window should be a decent size.

Mozilla 0.9.9+
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020418

Comment 1

16 years ago
ooh, oji
Assignee: beppe → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 2

16 years ago
Confirming with another yahoogroup !

Build ID 2002050308 - WinXP - JRE 1.4.0
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
The hight and width of the applet are specified as

&(innerWidth-200)

and

&(innerHeight-160)

If you change these to different values (say 800x600), the applet will open with
a decent size. Looks like innerWidth/innerHeight don't have the correct values
when the applet is displayed.
(Reporter)

Comment 4

16 years ago
Well, we usually do not control over the source code of the HTMLs, such as yahoo
groups, so we cannot change the values.

Is it possible to change the size without changing the source ? If so, please
tell me how.

Another interesting point: Why does the applet opens in IE in an acceptable
size, but not in mozilla. I guess, the code for both would be the same.

Thanks

Ajay
(Reporter)

Comment 5

16 years ago
In Reply to "Comment #3 From Marcus Fellinger"

> The hight and width of the applet are specified as
> &(innerWidth-200) and &(innerHeight-160)
> If you change these to different values (say 800x600), the applet 
> will open with a decent size. Looks like innerWidth/innerHeight
>  don't have the correct values when the applet is displayed.

Tried it: Did not work. Saved a local copy of them html page, changed the values
and loaded the HTML page again: Same result.

I could really use this, if someone has a fix / work around.

Thanks
Ajay

Comment 6

15 years ago
Hi Ajay,

The original code reads:

height="innerHeight-xxx" width="innerWidth-yyy", xxx and yyy being numeric
constants. Did you change xxx and/or yyy? Or did you change the code to read

height="400" width="1000", or whatever fits on your screen?
(Reporter)

Comment 7

15 years ago
Marcus,

The original code belogs to Yahoo Groups, and opens fine in IE. I have not tried
opening the link in IE myself (I despise IE), but have heard from other people
that it works fine in IE.

Tried again with 2002072208 build on XP: unsucessful.

Modfying the code locally and using that page would be a work around rather than
a bug fix. Actually, I am not even sure if it is a bug or not...

As a side note, I have been able to sucessfully use other Java applets in mozilla :)

Thanks

Ajay Gautam

Comment 8

15 years ago
Yes, it is a workaround. And this workaround shows that Mozilla has a problem
with innerWidth/innerHeight. Are these two part of the DOM? I'm able to use
other Java-Applets.

Does the same problem happen, if the java applet is replaced with another object
or an iframe?

Thanks

Marcus
(Reporter)

Comment 9

15 years ago
Marcus,

> Are these two part of the DOM?
> Does the same problem happen, if the java applet is replaced with 
> another object or an iframe?

I am not sure if I understand what you are talking about. If there is something
that you want me to try, do let me know. I will report back with results...

Thanks

Ajay

Comment 10

15 years ago
Hmmm, maybe I wasn't specific enough.

We know that specifying an applets size relative to innerWidth/innerHeight
doesn't work. But what happens if we replace the APPLET-Tag with something else,
and specify the size of the new object relative to innerWidth/innerHeight.

So this would mean taking the Source-Code of the page, and replacing the
APPLET-Tag with e.g. an IFRAME-Tag. How big is the resulting iframe?

The alternative would be to write a short javascript, that get's the values for
innerWidth/innerHeight and output's them to the page. What are the initial
values? What about other width/height measurements (window/screen)? Do the
values change when the window is resized?
(Reporter)

Comment 11

15 years ago
I would be happy to help, but I am a little short on web programming (Java
script etc). I am hearing IFRAME for the first time.

Today I downloaded the applet code (from yahoo group) and changed the "inner"
values, but did not have any success.

If there are a few specific steps that you want me to take and report back, I
will  be happy to do so.

Thanks

Ajay

Comment 12

15 years ago
Created attachment 93774 [details]
Modified Yahoo! chat

This is a modified version of
http://de.groups.yahoo.com/christliche-singles/chat. The chat-applet should be
800x600 pixels in size.

Updated

15 years ago
Attachment #93774 - Attachment description: Modifizierter Yahoo! Chat → Modified Yahoo! chat

Comment 13

15 years ago
Created attachment 93775 [details] [diff] [review]
This is a patch for http://de.groups.yahoo.com/christliche-singles/chat

This is a patch that modifies
http://de.groups.yahoo.com/christliche-singles/chat so the chat-window has a
size of 800x600 pixels. The same modifications should also work for other
Yahoo! Chat sites.

Comment 14

15 years ago
Hi Ajay,

I attached a modified version of a Yahoo! Chat site, as well as patch containing
the modifications I made. Could you take a look at it? I think this should also
help to pinpoint the problem.

Marcus
(Reporter)

Comment 15

15 years ago
Wow, that worked real good :)

Actually, I was converting
     height="&{innerHeight-200};"
to
     height="&{innerHeight-400};"
instead if
     height="400".

Anyway, any plans to fix the root cause of this ?

Thanks

Ajay Gautam

Comment 16

15 years ago

*** This bug has been marked as a duplicate of 161139 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 17

15 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.