In the add ons manager, when you click on Preferences to change the preferences for an add-on , all you get is a description o9f the add on, and you can not change any preferences.

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
2 months ago
2 months ago

People

(Reporter: Jack Nathanson, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

1. Go into Add-ons Manager.
2. Go to an add-on that has a Preferences tab.
3. Click on the Preferences tab.


Actual results:

All I get is a general description of the add-on in question.


Expected results:

I should have got some sort of window enabling me to change my preferences.
(Reporter)

Updated

2 months ago
Summary: In the add ons manager, when you click on Preferences to change the preferences for an add o , all you get is a description o9f the add on, and you can not change any preferences. → In the add ons manager, when you click on Preferences to change the preferences for an add-on , all you get is a description o9f the add on, and you can not change any preferences.

Updated

2 months ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
What specific extension are you having this problem with?
Flags: needinfo?(nathanson1947)
(Reporter)

Comment 2

2 months ago
Video Downloader Pro, Google Translator for Firefox, In My Pocket, Search Preview, Text Link, Tin Eye Reverse Image Search, and Linkificator all seem to have this problem.

On the other hand, Adblock Plus and IM Translator:Translator,Dictionary,TTS seem to work normally.
Flags: needinfo?(nathanson1947)
I didn't try all the extensions you mentioned but the 3 I did try all use inline preferences, which means their preferences show up at the bottom of the details page (the page you described as "a general description of the add-on")

Can you check if the preferences are present there and if not, attach a screenshot?
Flags: needinfo?(nathanson1947)
(Reporter)

Comment 4

2 months ago
The preferences did not appear at the bottom. There does not appear to be any way to attach a screenshot to this report, at least not on a Mac.
Flags: needinfo?(nathanson1947)
(Reporter)

Comment 5

2 months ago
Created attachment 8933514 [details]
The screenshot requested.
The "Terms of Service" and "Privacy Policy" links are the full contents of the Video Download Helper options page.  What does it looks like with Google Translator?
Flags: needinfo?(nathanson1947)
(Reporter)

Comment 7

2 months ago
Created attachment 8933546 [details]
GOOGLE TRANSLATOR FOR FIREFOX.png
Flags: needinfo?(nathanson1947)
Those are the extension's preferences at the bottom of the page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.