rhino cannot get indexed properties if two getters are defined

VERIFIED DUPLICATE of bug 218163

Status

Rhino
Core
--
enhancement
VERIFIED DUPLICATE of bug 218163
16 years ago
15 years ago

People

(Reporter: frank luo, Assigned: Norris Boyd)

Tracking

other
1.5R5
x86
Windows 2000

Details

(Reporter)

Description

16 years ago
According to Java specs, a JavaBean indexed properties can be defined by two 
sets of getters/setters. For example, a Java Bean with *ONE* property 
of "counts" can be defined as:

public class Foo()
{
  public int getCounts(int i);
  public void setCounts(int i, int count);
  public int[] getCounts();
  public void setCounts(int counts[]);
}

However, rhino is not able to find this property. For example, the following 
code will not work:

js> foo.counts[0] = 1;

Comment 1

15 years ago
Changing the severity to enhancement as it is somethong that was never supported
and is not required by LiveConnect specs.
Severity: blocker → enhancement

Comment 2

15 years ago
In reality it is the bug 218163 that is a duplicate of this one but it was
218163 that got fixed.

With that fix "foo.counts[0] = 1;" works as expected.



*** This bug has been marked as a duplicate of 218163 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Marking Verified -
Status: RESOLVED → VERIFIED

Comment 4

15 years ago
Trageting as resolved against 1.5R5
Target Milestone: --- → 1.5R5
You need to log in before you can comment on or make changes to this bug.