Option to block notifications by default

RESOLVED DUPLICATE of bug 1364942

Status

()

enhancement
RESOLVED DUPLICATE of bug 1364942
2 years ago
2 years ago

People

(Reporter: bernat, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171115002005

Steps to reproduce:

Go to a random web site, like http://www.liberation.fr/


Actual results:

A doorhanger popup appears to ask if I want to get notifications.


Expected results:

When browsing a site with webnotifications, we get a doorhanger with the option to allow/disallow/do nothing. I think most users only want notifications on very few sites and many sites are now abusing this mechanism. Moreover, only one click is needed to enable notifications while two clicks are needed to block them.

At least, an option for users to set the default permission for notifications would be great. Currently, the only option is to disable all notifications in about:config.
Severity: normal → enhancement
Component: Untriaged → DOM: Push Notifications
Product: Firefox → Core
Hi, thanks for the report! There's now a WebExtension API to do this, which behaves as you describe: sites for which you've explicitly granted permission can still show notifications, but the default can be changed to block. You can also do this without installing any extensions by flipping the `permissions.default.desktop-notification` pref to 2 (`Services.perms.DENY_ACTION`).
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364942
You need to log in before you can comment on or make changes to this bug.