Closed Bug 1421100 Opened 2 years ago Closed 2 years ago

Update win32 builders to rust 1.23.0-beta.2

Categories

(Firefox Build System :: General, defect)

Unspecified
Windows
defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: rillian, Assigned: rillian)

References

Details

Attachments

(1 file)

Rust 1.22 fails to compile gkrust for win32 with -Clto. We think this is just address space exhaustion (bug 1417268) and Rust 1.23 doesn't show the issue because of more efficient code representation passed to llvm.

Using 64-bit Rust to compile for win32 is blocked on bug 1401647. In the meantime, bump win32 builders to 1.23.0-beta.1 so we're not limited to 1.21 as a minimum version. Rust 1.23 is expected to be in stable release before the current Firefox Nightly goes to beta in January.
I don't think we should use rustc betas.
Comment on attachment 8932279 [details]
Bug 1421100 - Update win32 builders to rust 1.23.0-beta.2.

https://reviewboard.mozilla.org/r/203296/#review208910

::: taskcluster/ci/toolchain/windows.yml:149
(Diff revision 1)
> -win32-rust-1.21:
> +win32-rust-1.23.0-beta.1:
>      description: "rust repack"
>      treeherder:
>          kind: build
>          platform: toolchains/opt
> -        symbol: TW32(rust)
> +        symbol: TW32(rust-beta)

Doesn't seem particularly useful to change the Treeherder symbol here.
Attachment #8932279 - Flags: review+
Attachment #8932279 - Flags: review?(core-build-config-reviews)
Comment on attachment 8932279 [details]
Bug 1421100 - Update win32 builders to rust 1.23.0-beta.2.

https://reviewboard.mozilla.org/r/203296/#review208910

> Doesn't seem particularly useful to change the Treeherder symbol here.

I thought it was more clear, and means I don't have to change it to test a stable release in parallel. I'll take it out.
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2f814fa49aa
Update win32 builders to rust 1.23.0-beta.1. r=ted
(In reply to Mike Hommey [:glandium] from comment #2)

> I don't think we should use rustc betas.

I know, but that's not the policy Mozilla decided on. :/
Blocks: 1421349
Backed out for failing Windows x32 web platform tests /encoding/api-replacement-encodings.html
Backout https://hg.mozilla.org/integration/autoland/rev/488e18d45352a9845ce509d3c1a0b22ab642a6ce

Push causing the failures https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=c2f814fa49aac64334358279b3dc186944a967d4

Failure log https://treeherder.mozilla.org/logviewer.html#?job_id=148237887&repo=autoland&lineNumber=3463

INFO - 
3463
19:02:13     INFO - TEST-UNEXPECTED-FAIL | /encoding/api-replacement-encodings.html | Label for "replacement" should be rejected by API: csiso2022kr - assert_throws: function "function() { new TextDecoder(label); }" did not throw
3464
19:02:13     INFO - @http://web-platform.test:8000/encoding/api-replacement-encodings.html:14:17
3465
19:02:13     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1489:20
3466
19:02:13     INFO - test@http://web-platform.test:8000/resources/testharness.js:511:9
3467
19:02:13     INFO - @http://web-platform.test:8000/encoding/api-replacement-encodings.html:13:13
3468
19:02:13     INFO - @http://web-platform.test:8000/encoding/api-replacement-encodings.html:12:9
3469
19:02:13     INFO - @http://web-platform.test:8000/encoding/api-replacement-encodings.html:9:5
3470
19:02:13     INFO - @http://web-platform.test:8000/encoding/api-replacement-encodings.html:8:1
Flags: needinfo?(giles)
Reproduces upstreeam. I filed hsivonen/encoding_rs#26
Flags: needinfo?(giles)
Duplicate of this bug: 1421349
(In reply to Mike Hommey [:glandium] from comment #2)
> I don't think we should use rustc betas.

We agreed that it was OK to *use* betas for our CI builds as long as we didn't *require* a non-release version, with the intention being that we would always wind up shipping release Firefox with a release Rust.
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #11)
> (In reply to Mike Hommey [:glandium] from comment #2)
> > I don't think we should use rustc betas.
> 
> We agreed that it was OK to *use* betas for our CI builds as long as we
> didn't *require* a non-release version, with the intention being that we
> would always wind up shipping release Firefox with a release Rust.

But the goal here is to allow to bump the requirement to 1.22, which we can't build with. So effectively, this would make the beta a requirement.
(In reply to Mike Hommey [:glandium] from comment #12)

> But the goal here is to allow to bump the requirement to 1.22, which we
> can't build with. So effectively, this would make the beta a requirement.

The build failure with 1.22 only affects automation, so there should be no requirement on downstream builders to use beta rust.
There is no reason for it not to affect local builds of 32-bits Firefox.
OS: Unspecified → Windows
Summary: Update win32 builders to rust 1.23.0-beta.1 → Update win32 builders to rust 1.23.0-beta.2
1.23.0-beta.2 should be out soon with a patch which addresses the encoding_rs test regression for me.
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5986b2cc92b
Update win32 builders to rust 1.23.0-beta.2. r=ted
https://hg.mozilla.org/mozilla-central/rev/e5986b2cc92b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
So thanks to this change we're now in a funny position, where the rust-1.23.0-beta.2 job is downloading 1.24.0-beta.1, and that version breaks building slog.
oh, and 1.23.0 is not released yet, so we can't even workaround by forcing back to version 1.23.0, because it doesn't exist.
and there doesn't seem to be a way to download specific beta versions...
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5afa32a16a2f
Followup for bug 1421100: deterministically download rustc 1.23.0-beta.2. r=me, a=bustage on a CLOSED TREE
Depends on: 1428009
These changes improved performance on two of our tests:

== Change summary for alert #11120 (as of Wed, 10 Jan 2018 05:34:27 GMT) ==

Improvements:

  6%  Stylo Servo_DeclarationBlock_SetPropertyById_Bench windows7-32 opt      519,893.42 -> 488,779.50
  6%  Stylo Servo_DeclarationBlock_SetPropertyById_WithInitialSpace_Bench windows7-32 opt 521,590.29 -> 491,489.42

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=11120
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.