Closed Bug 1421206 Opened 5 years ago Closed 5 years ago

Crash in ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke

Categories

(Core :: Audio/Video: cubeb, defect, P2)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: calixte, Assigned: achronop)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-463ca423-2588-4c6d-972f-75a410171128.
=============================================================

Top 10 frames of crashing thread:

0  @0x7fff7851ee76 
1 XUL google_breakpad::ReceivePort::WaitForMessage toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm:249
2 XUL google_breakpad::CrashGenerationClient::RequestDumpForException toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc:67
3 XUL google_breakpad::ExceptionHandler::WriteMinidumpWithException toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:375
4 XUL google_breakpad::ExceptionHandler::SignalHandler toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:616
5  @0x7fff78658f59 
6  @0x7fff5531b698 
7  @0x7fff78484309 
8  @0x7fff7844c35f 
9 XUL ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke media/libcubeb/src/cubeb_audiounit.cpp:628

=============================================================

There are 21 crashes in nightly 59 with buildid 20171127220446 so just after the patch [1] landed.
:achronop, could you investigate please ?

[1] https://hg.mozilla.org/mozilla-central/rev/50ea7f713c35
Flags: needinfo?(achronop)
Assignee: nobody → achronop
Flags: needinfo?(achronop)
Rank: 15
Priority: -- → P2
Yeah, it's an oneliner from that commit. I'm fixing it now.
I got both of my nightly/central session crashing when I changed the audio device (both output and input) in the sound preferences
https://crash-stats.mozilla.com/report/index/463ca423-2588-4c6d-972f-75a410171128
That's right, by playback something and changing your default output device will repro this. I am pushing a fix now.
Pushed in cubeb repo for review: https://github.com/kinetiknz/cubeb/pull/381
Depends on: 1421267
Crash Signature: [@ ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] → [@ ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] [@ abort | ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke]
Crash Signature: [@ ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] [@ abort | ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] → [@ ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] [@ abort | ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] [@ __pthread_kill | abort | ___ZL36audiounit_property_l…
Crash Signature: ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] → ___ZL36audiounit_property_listener_callbackjjPK26AudioObjectPropertyAddressPv_block_invoke] [@ GCC_except_table73]
Duplicate of this bug: 1421776
https://hg.mozilla.org/mozilla-central/rev/e12f1eae1569
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.