browser.search.openintab preference doesn't work from the awesome bar

RESOLVED DUPLICATE of bug 1394304

Status

()

enhancement
RESOLVED DUPLICATE of bug 1394304
2 years ago
2 years ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 affected)

Details

(Whiteboard: [fxsearch])

This may be a duplicate of bug 429183, but that is a really old bug, and also seems to be about someone explicitly removing the search box.

The search box is missing by default in 57+, and if one sets the browser.search.openintab pref to `true`, searches from the awesome bar (which is really the only way that most people will search in 57+) do not open in new tabs, rendering the pref virtually useless.

We were hoping to expose this pref to extensions via bug 1420969, but don't think that's wise until this is fixed.

Is this something that is planned to be fixed in the near future? I couldn't find a bug about it other than 429183.
Reporter

Updated

2 years ago
Priority: P4 → --
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394304
You need to log in before you can comment on or make changes to this bug.