Closed Bug 1421307 Opened 2 years ago Closed 2 months ago

Intermittent accessible/tests/browser/browser_shutdown_acc_reference.js | leaked 1 window(s) until shutdown [url = about:newtab]

Categories

(Core :: Disability Access APIs, defect, P5)

defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Duplicate of this bug: 1421331
There are 33 failures in the last 7 days.
They occur on OS X 10.10 - debug.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?repo=mozilla-inbound&job_id=174947369&lineNumber=1700
07:59:51     INFO - TEST-INFO | Main app process: exit 0
07:59:51    ERROR - TEST-UNEXPECTED-FAIL | accessible/tests/browser/browser_shutdown_acc_reference.js | leaked 1 window(s) until shutdown [url = about:newtab]
07:59:51     INFO - TEST-INFO | accessible/tests/browser/browser_shutdown_acc_reference.js | windows(s) leaked: [pid = 1898] [serial = 7]
07:59:51     INFO - runtests.py | Application ran for: 0:01:33.420495
07:59:51     INFO - zombiecheck | Reading PID log: /var/folders/ls/vl802vr13hs0wzpnvd_7syjw00000w/T/tmpW8SgDUpidlog
surkov: Could you please take a look at this?
Flags: needinfo?(surkov.alexander)
Whiteboard: [stockwell needswork]
Yura, as the test author, do you have any clue why this test might be special? It is only one failing test among all browser_shutdown_ tests [1].

[1] https://bugzilla.mozilla.org/buglist.cgi?list_id=14121081&short_desc_type=allwordssubstr&f1=OP&short_desc=browser_shutdown_&f0=OP&resolution=---&f4=CP&query_format=advanced&j1=OR&f3=CP&component=Disability%20Access%20APIs&product=Core
Flags: needinfo?(surkov.alexander) → needinfo?(yzenevich)
This bug has failed 56 times in the last 7 days, most failures occur on linux32/64 platform and a few on windows. All failures are on debug build type.

A recent log:
https://treeherder.mozilla.org/logviewer.html#?job_id=195646099&repo=autoland&lineNumber=1879

 TEST-INFO | Main app process: exit 0
[task 2018-08-23T23:36:03.398Z] 23:36:03    ERROR - TEST-UNEXPECTED-FAIL | accessible/tests/browser/browser_shutdown_acc_reference.js | leaked 1 window(s) until shutdown [url = about:newtab]
[task 2018-08-23T23:36:03.400Z] 23:36:03     INFO - TEST-INFO | accessible/tests/browser/browser_shutdown_acc_reference.js | windows(s) leaked: [pid = 1148] [serial = 7]
[task 2018-08-23T23:36:03.401Z] 23:36:03     INFO - runtests.py | Application ran for: 0:01:32.789999
[task 2018-08-23T23:36:03.402Z] 23:36:03     INFO - zombiecheck | Reading PID log: /tmp/tmpTij4Wopidlog
[task 2018-08-23T23:36:03.404Z] 23:36:03     INFO - ==> process 1060 launched child process 1082
[task 2018-08-23T23:36:03.408Z] 23:36:03     INFO - ==> process 1060 launched child process 1123
[task 2018-08-23T23:36:03.408Z] 23:36:03     INFO - ==> process 1060 launched child process 1148
[task 2018-08-23T23:36:03.410Z] 23:36:03     INFO - ==> process 1060 launched child process 1191
[task 2018-08-23T23:36:03.411Z] 23:36:03     INFO - ==> process 1060 launched child process 1220
[task 2018-08-23T23:36:03.412Z] 23:36:03     INFO - ==> process 1060 launched child process 1237
[task 2018-08-23T23:36:03.413Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1123
[task 2018-08-23T23:36:03.413Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1220
[task 2018-08-23T23:36:03.414Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1191
[task 2018-08-23T23:36:03.415Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1237
[task 2018-08-23T23:36:03.416Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1082
[task 2018-08-23T23:36:03.416Z] 23:36:03     INFO - zombiecheck | Checking for orphan process with PID: 1148
[task 2018-08-23T23:36:03.416Z] 23:36:03     INFO - Stopping web server
[task 2018-08-23T23:36:03.432Z] 23:36:03     INFO - Stopping web socket server
[task 2018-08-23T23:36:03.453Z] 23:36:03     INFO - Stopping ssltunnel
[task 2018-08-23T23:36:03.472Z] 23:36:03     INFO - TEST-INFO | leakcheck | default process: leak threshold set at 0 bytes
[task 2018-08-23T23:36:03.472Z] 23:36:03     INFO - TEST-INFO | leakcheck | plugin process: leak threshold set at 0 bytes
[task 2018-08-23T23:36:03.472Z] 23:36:03     INFO - TEST-INFO | leakcheck | tab process: leak threshold set at 0 bytes
[task 2018-08-23T23:36:03.472Z] 23:36:03     INFO - TEST-INFO | leakcheck | geckomediaplugin process: leak threshold set at 20000 bytes
[task 2018-08-23T23:36:03.472Z] 23:36:03     INFO - TEST-INFO | leakcheck | gpu process: leak threshold set at 0 bytes


:surkov: Can you please take a look at this bug?
Flags: needinfo?(surkov.alexander)
Whiteboard: [stockwell unknown] → [stockwell needswork]
Update:
There have been 68 failures in the last 7 days and 139 failures in the last 21 days.
The failures occur only on debug.
Failures per platform:

- linux64: 60
- linux32: 7
- linux64-ccov: 1 

Recent relevant log file:
https://treeherder.mozilla.org/logviewer.html#?job_id=197003292&repo=autoland&lineNumber=1914
There are 73 failures in the last 7 days. 
Most of them on linux64 - debug
Samuel, seems that the failures have started from this push https://hg.mozilla.org/integration/mozilla-inbound/rev/9ea974e9f568ec4ef151702c35333d850c38ab5d
Can you please take a look?
Flags: needinfo?(samuel.thibault)
Mmm. Unfortunately I am not able to reproduce the issue on my box. I have to say I have a hard time imagining how this push could have this consequence. Did anybody manage to test with vs without the change?

AIUI from the warning message, the issue is that a window tab is left open by the test? This seems completely unrelated to the change in HyperTextAccessible::TextBounds, which I don't even see how could get called by this test :/
Flags: needinfo?(samuel.thibault)
:surkov, there are 80 failures in the last 7 days and 183 in the last 30 days.
Is there something that you or someone else can do, or should we go ahead and disable it on linux64-debug until there will be a fix?
Added a patch in case we decide that disable the test.
Assignee: nobody → ebalazs
Attachment #9006523 - Flags: review?(jmaher)
Assignee: ebalazs → nobody
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9287b5dfb52
Disable browser_shutdown_acc_reference.js on linux64 debug for frequent failures. r=jmaher
Keywords: checkin-needed
(In reply to Narcis Beleuzu [:NarcisB] from comment #48)
> :surkov, there are 80 failures in the last 7 days and 183 in the last 30
> days.
> Is there something that you or someone else can do, or should we go ahead
> and disable it on linux64-debug until there will be a fix?

sure, since it hits too often
Flags: needinfo?(surkov.alexander)

Looks like it stopped 4m ago

Flags: needinfo?(yzenevich)

(In reply to Yura Zenevich [:yzen] from comment #62)

Looks like it stopped 4m ago

let's close this one then?

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → RESOLVED
Closed: 6 months ago2 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.