Closed Bug 1421472 Opened 4 years ago Closed 3 years ago

Flickering text rendering in text area

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected

People

(Reporter: ted, Assigned: kvark)

References

Details

(Whiteboard: [wr-reserve])

Attachments

(4 files)

Attached image flickering
I pasted some text into a Bugzilla attachment textarea on another bug, and I noticed that when I scrolled to the top there was part of a line of text visible at the bottom and it was flickering. Attached is a short screen capture of the flickering.

STR:
- Paste some text into the text area on the Bugzilla attachment screen such that a partial line of text is visible when scrolled to the top.
- Scroll down then back up
I forgot to mention, this is on today's nightly on Windows 10.
> NVIDIA Quadro M2000
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Whiteboard: [wr-mvp] [triage]
Version: unspecified → Trunk
Attached video 2017-11-29_01-27-41.mp4
Confirmed in
Nightly 59 x64 20171128100440 de_DE 5b33b070378ae0806bed0b5e5e34de429a29e7db @ Debian Testing (KDE, Radeon RX480).
fresh profile: layers.acceleration.force-enabled, gfx.webrender.enabled, gfx.webrender.blob-images, image.mem.shared, gfx.webrender.debug.alpha-primitives, gfx.webrender.highlight-painted-layers

https://bugzilla.mozilla.org/enter_bug.cgi?product=Core

See attached video.

Fixed by disabling WebRender.
Attached video 2017-11-29_01-31-17.mp4
(Wanted to test layout.display-list.retain;false here.)

This is a wonderful example where the blinking cursor (above "STR:" at the bottom) is the cause.
Has STR: --- → yes
OS: Windows 10 → All
This is caused by a limitation in WebRender's API which is tracked by bug 1409442. Setting dependency.

(The caret and the text should be clipped by two different clips but scrolled by the same scroll frame. Due to the limitation, whenever the caret is visible, the text is clipped to the same clip as the caret (instead of something smaller) and is drawn outside of where it should be.)
Depends on: 1409442
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-mvp] [triage][wr-reserve-candidate]
Whiteboard: [wr-mvp] [triage][wr-reserve-candidate] → [wr-reserve]
Duplicate of this bug: 1422914
Assignee: nobody → kvark
Duplicate of this bug: 1452086
This, as expected, appears to be fixed by bug 1409442.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.