Sidebar Address Book, sort widget remains in descending order

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment, 1 obsolete attachment)

665 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Branch build 2002-05-03: WinMe, Mac 10.1.3, Linux RH 7.1

Overview: In the Sidebar Address Book select the Name column and the sort widget
changes from ascending to descending order and remains in the descending state.

Steps to reproduce:
1. Open a profile that has address book entries
2. Add the Address Book to the Sidebar
3. Select the Name column and it should change the sort
4. Select the Name column multiple times to change the sort order

Actual Results: The cards are resorted but the sort widget remains in descending
order.

Expected Results: The directin of the widget should reflect the actual state of
the cards
(Reporter)

Comment 1

16 years ago
Marking nsbeta1 for RTM consideration even though I realize that this is
probably a low priority. It would be nice for the widget to reflect the actual
sort order of the cards.
Keywords: nsbeta1

Comment 2

16 years ago
nsbeta1- per mail triage.
Keywords: nsbeta1 → nsbeta1-
(Reporter)

Comment 3

16 years ago
Marking nsbeta1 so that the Sidebar AB widgets reflect the true
ascending/descending state.
Keywords: nsbeta1- → nsbeta1

Comment 4

15 years ago
I still this behavior. 2002121608, windows.

Comment 5

15 years ago
Mail triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]

Comment 6

15 years ago
Reassigning.
Assignee: racham → cavin

Comment 7

15 years ago
Reassigning.
Assignee: cavin → shliang
(Assignee)

Comment 8

15 years ago
Created attachment 113609 [details] [diff] [review]
patch
(Assignee)

Updated

15 years ago
Attachment #113609 - Flags: superreview?(sspitzer)
Attachment #113609 - Flags: review?(cavin)

Comment 9

15 years ago
Comment on attachment 113609 [details] [diff] [review]
patch

r=cavin.
Attachment #113609 - Flags: review?(cavin) → review+
Comment on attachment 113609 [details] [diff] [review]
patch

the id of "addressbookList" is used by both the addressbook sidebar panel and
the tree in the select addresses dialog.  (the one you get from the compose
window if you hit the "Address" toolbar button)

it looks like that dialog has the same bug as the addressbook sidebar panel.

from abCommon.js:

function InitCommonJS()
{
  dirTree = document.getElementById("dirTree");
  abList = document.getElementById("addressbookList");
  gAbResultsTree = document.getElementById('abResultsTree');
}

Can you just do:

-  if (dirTree && gAbView) {
+  if ((dirTree || abList) && gAbView) {

while your fix would work, this removes the extra call to getElementById().

Can you verify that it fixes both the sidebar panel and the select addresses
dialog?

(you should look for this bug on the select addresses dialog and take it, as
you'll be fixing it, too.)
Attachment #113609 - Flags: superreview?(sspitzer) → superreview-
(Assignee)

Comment 11

15 years ago
Created attachment 114291 [details] [diff] [review]
changing to abList
Attachment #113609 - Attachment is obsolete: true
(Assignee)

Comment 12

15 years ago
and it does fix both the sidebar panel and select addresses dialog
(Assignee)

Updated

15 years ago
Attachment #114291 - Flags: superreview?(sspitzer)
Comment on attachment 114291 [details] [diff] [review]
changing to abList

r/sr=sspitzer

nice work.

asking for 1.3 final approval on shuehan's behalf.

shuehan, before you check in, could you add a comment to this code indicating
why we need to check both dirTree and abList?
Attachment #114291 - Flags: superreview?(sspitzer)
Attachment #114291 - Flags: superreview+
Attachment #114291 - Flags: review+
Attachment #114291 - Flags: approval1.3?

Comment 14

15 years ago
Comment on attachment 114291 [details] [diff] [review]
changing to abList

a=asa (on behalf of drivers) for checkin to 1.3 final.
Attachment #114291 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 15

15 years ago
marking fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

15 years ago
Trunk build 2003-03-03: WinXP, Linux RH 8, Mac 10.1.5
Verified Fixed. 

Note: Could only check the Sidebar Address Book in the Browser since it is no
longer available in any Mail component. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.