Closed Bug 142161 Opened 19 years ago Closed 16 years ago

Need an API to check key object properties

Categories

(NSS :: Libraries, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 244914

People

(Reporter: julien.pierre, Assigned: wtc)

References

Details

We need to expose a way to check the properties of key objects living in PKCS#11 
tokens. For instance, PSM needed to know if a key object is extractable or not.
Severity: normal → enhancement
Priority: -- → P2
Target Milestone: --- → 4.0
OS: Windows 2000 → All
Hardware: PC → All
Blocks: 137506
QA Contact: bishakhabanerjee → jason.m.reid
As Bob were able to produce a working patch for bug 137506, is this bug fixed?
So I think some properties, like extractable probably needs to have it's own dedicated function, but this bug is about getting to access to random PKCS #11 attributes on keys, which was fixed bug 244914

*** This bug has been marked as a duplicate of 244914 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.