Closed Bug 1421747 Opened 4 years ago Closed 3 years ago

Image gets drawn on chrome with webrender

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected

People

(Reporter: noszalyaron4, Unassigned)

References

()

Details

(Keywords: correctness, nightly-community, Whiteboard: [wr-reserve])

Attachments

(4 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20171129111030

Steps to reproduce:

Enable webrender in the standard way. On a new profile I changed prefs gfx.webrender.enable, gfx.webrender.blob-images, layers.acceleration.force-enabled, image.mem.shared.

Visit https://fnatic.com/ and the overscrolled parts of the images are rendered on the chrome.

GPU is intel igpu.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Whiteboard: [wr-mvp] [triage]
Version: 59 Branch → Trunk
Attached video 2017-11-29_22-43-46.mp4
Nightly 59 x64 20171129111030 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: Dark Theme + layers.acceleration.force-enabled, gfx.webrender.enabled, gfx.webrender.blob-images, image.mem.shared

When using the Dark Theme, I see a thin transparent line above the website (UI border?). Images can overlap, even the scrollbar.

(It made my main profile UI flicker white for a moment, but I couldn't reproduce it so far. Nothing unusual on about:support.)
I can't reproduce it with dark theme only with default. Also I succesfully saw this on the original machine with Gnome3 (Wayland), Gnome3 (xorg), xfce. And on my laptop, which got the same generation of intel cpu without video card too (so just igpu), I see it too with xfce.
Attached image another.png
Sorry to spam but I forgot to write it, but it seems like a recent issue because while I tried to reproduce in my laptop I saw that I had 11-28 nightly and the issue was not there but after update to latest 11-29 the issue appered.
Nightly 59 x64 20171129220149 de_DE @ Debian Testing (Gnome, Radeon RX480)
I can exactly reproduce it here.

This bug is also present in builds from 2017-11-15, 2017-11-10 and 2017-10-17.
(layers.acceleration.force-enabled, gfx.webrender.enabled, layout.display-list.retain;false)
Also reproducible on Windows 10.
OS: Linux → All
Hardware: x86_64 → All
Priority: -- → P3
Whiteboard: [wr-mvp] [triage] → [wr-reserve]
Is anybody still seeing this, on Windows or Linux?
Flags: needinfo?(noszalyaron4)
Flags: needinfo?(jan)
With current nightly on linux I can't reproduce it. To be sure that I checked on an older version if the bug "works" with new content on the site.
Flags: needinfo?(noszalyaron4)
Radeon RX480 @ Debian Testing:

mozregression --find-fix --bad 2017-11-30 --good 2018-01-09 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://fnatic.com/"
> 5:58.04 INFO: First good revision: 99a3b09ac1898eb1db05430e2876d6643ba0d4a8 (2017-12-06)
> 5:58.04 INFO: Last bad revision: 18a9cb5cb32d0e8031d0a80901b199d5e9827d83 (2017-12-05)
> 5:58.04 INFO: Pushlog:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=18a9cb5cb32d0e8031d0a80901b199d5e9827d83&tochange=99a3b09ac1898eb1db05430e2876d6643ba0d4a8
(mozregression was slow after this step and I got many "Unable to find build info using the taskcluster route", so I cancelled here.)

mozregression --find-fix --bad 2017-12-05 --good 2017-12-06 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://fnatic.com/"
> 6:06.89 INFO: First good revision: 9f8cde87eaa7a7b164c999a369b4835c7ec68e62
> 6:06.89 INFO: Last bad revision: 3abc6abd34bf81eb3bd29f21630cbefa2f43947b
> 6:06.89 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3abc6abd34bf81eb3bd29f21630cbefa2f43947b&tochange=9f8cde87eaa7a7b164c999a369b4835c7ec68e62

The fix was:
> 52277221fade	Kartikaya Gupta — Bug 1422317 - Update webrender to commit b7714b1d4348c00682b5643ea0e3f0b15adaeda5. r=jrmuizel
Depends on: 1422317
Flags: needinfo?(jan)
Thanks!
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.