Closed Bug 1421780 Opened 2 years ago Closed 10 months ago

"this" is optimized away

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mhammar31, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image thisisoptimizedaway.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

In firefox debugger.
Execution stopped because an exception.


Actual results:

"this" is optimized away! It can't be right that the only way to find the context actually is removed. 
And if I try to add this as an watch then that "this" points to window ( see other bug-report from me ) 


Expected results:

I think that "this" never should be optimized away. It is too important.
Component: Dev Kit → Developer Tools: Debugger
Product: Developer Ecosystem → Firefox
Summary: this is optimized away → "this" is optimized away
Product: Firefox → DevTools

mattias, can you share steps to reproduce?

Flags: needinfo?(mhammar31)
Blocks: dbg-control

closing as there is no str. Happy to re-open if we get one

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.