Closed Bug 1421937 Opened 2 years ago Closed 2 years ago

"Synced Tabs" sidebar's laptop image looks bad with Windows's light gray background color

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed

People

(Reporter: cpeterson, Assigned: eoger)

Details

Attachments

(4 files, 1 obsolete file)

STR:
1. Using Firefox Nightly 59 on Windows 10, open the Synced Tab sidebar (in a new user profile that is not logged into Sync): View menu > Sidebar menu > Synced Tabs.
2. Examine the outline of the Synced Tabs sidebar's laptop image.

RESULT:
On Windows, the Synced Tabs sidebar's background color is light gray, which causes the laptop image's dark gray cloud outlines to look like unintentional rendering artifacts. See the attached screenshots.

This laptop image is new in Nightly 59.
On macOS, the Synced Tabs sidebar's background color is dark gray so the dark gray cloud outlines do not look bad.
Flags: needinfo?(rfeeley)
Pixel sampled in Photoshop (and tested in my own Windows 8 install) the Windows sidebar background is actually pure white (#FFFFFF).

Is this a bug?

I thought it was supposed to be light grey on every desktop OS?
Flags: needinfo?(rfeeley) → needinfo?(cpeterson)
(In reply to Ryan Feeley [:rfeeley] from comment #2)
> Pixel sampled in Photoshop (and tested in my own Windows 8 install) the
> Windows sidebar background is actually pure white (#FFFFFF).
> 
> Is this a bug?
> 
> I thought it was supposed to be light grey on every desktop OS?

I don't know what the intended design. I see the same sidebar color in Firefox 57, Beta 58, and Nightly 59. On my Mac, the background is gray (as shown in screenshot attachment 8933230 [details]). On my Windows 10 laptop, the background is white (as shown in screenshot attachment 8933229 [details]).

I called my Windows sidebar color "light gray" above, but now that I look more closely, it really is pure white. My screen was just dim. :)
Flags: needinfo?(cpeterson)
Attached file sync-illustrations.zip (obsolete) —
Good find. Here are the two version (full heart and broken heart) to be simultaneously background and grey compatible. Look good eoger?
Flags: needinfo?(eoger)
It looks like the 2 provided illustrations are the same (broken heart in both images). Can you provide new ones Ryan?
Flags: needinfo?(eoger) → needinfo?(rfeeley)
Attached file sync-illustrations.zip
Oops! Now there are two bugs.
Attachment #8933779 - Attachment is obsolete: true
Flags: needinfo?(rfeeley)
I mean two hearts (one broken, one not). I will stop typing when people are talking to me.
Assignee: nobody → eoger
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8937512 [details]
Bug 1421937 - Update sync-illustration svgs.

https://reviewboard.mozilla.org/r/208198/#review214048

rs=me if rfeeley approves (which I assume he did as he supplied them :)
Attachment #8937512 - Flags: review?(markh) → review+
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/375663a2b771
Update sync-illustration svgs. r=markh
https://hg.mozilla.org/mozilla-central/rev/375663a2b771
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
I have reproduced this bug with Nightly 59.0a1 (2017-11-30) on Windows 10 , 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20180215111455
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [testday-20180216]
I have a question regarding the expected result. I verified the fix on Latest Nightly 60.0a1 and beta 59.0b11 using macOS 10.13, Ubuntu 16.04 x64 and Windows 10 x64, but I got two different behaviours: 

 - On Nightly the design is not present
 - On beta the design is present and fixed as it is mentioned in comment 12.

Which one is the intended result?
Flags: needinfo?(eoger)
We have had other bugs touching the sidebar/panel design (e.g bug 1434670), which explains why Nightly and Beta are different.
I don't think this warrants an uplift tough, let's leave it like this.
Flags: needinfo?(eoger)
You need to log in before you can comment on or make changes to this bug.