Closed Bug 1421953 Opened 3 years ago Closed 2 years ago

Requesting webm gives you ogg

Categories

(Core :: Audio/Video: Recording, enhancement, P3)

58 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1523563

People

(Reporter: pehrsons, Unassigned)

References

()

Details

Unexpectedly, requesting webm from MediaRecorder and giving it only an audio track to record will produce an ogg file.

Meanwhile the spec says, under MediaRecorderOptions:
> mimeType, of type DOMString 
>   The container and codec format(s) [RFC2046] for the recording,
>   which may include any parameters that are defined for the format.
>   If the UA does not support the format or any of the parameters specified,
>   it MUST throw a NotSupportedError DOMException.

This behavior can be observed on https://jsfiddle.net/pehrsons/y0p1xh0b/

audio/webm is rejected as not supported, but video/webm is accepted but then ignored when there is no video track.
Rank: 25
Priority: -- → P3

Fixed by bug 1523563.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1523563
You need to log in before you can comment on or make changes to this bug.