Closed Bug 1422079 Opened 2 years ago Closed 2 years ago

Add section context menu to help users who have difficulty hiding sections

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 60
Iteration:
60.3 - Feb 26
Tracking Status
firefox59 --- wontfix
firefox60 --- verified

People

(Reporter: Mardak, Assigned: rrosario)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [strings landed][AS60MVP] )

Attachments

(1 file)

> There's been feedback that users are having difficulty finding the New Tab Preferences panel to hide sections of New Tab.

> Proposing to add a "hide" button on each section to make it more visible. See spec for details.

> New Tab – Hide Section Spec https://mozilla.invisionapp.com/share/QFEPZRATX
uiwanted: From user studies, it looks like users don't even notice the top right on-hover controls for each section as well as not expecting the gear in the top right of the page. Does it make sense to add more controls in places that the user isn't even interacting with?
uiwanted: Potentially, instead of having the new modal, clicking "Hide" could open up the preference sidebar highlighting the section and auto-unchecking it? Maybe related, if we add this highlight related pref section, it could also be used for the usual (?) -> "New Tab Preferences >" link?
design says to show the Hide link, which on click opens up the pref pane immediately, and after some delay changes the pref, so that the checkbox unchecks and section disappears.

tspurway suggests we might want a pref to be able to experiment whether users interact and change their preferences this way.. or maybe not and ship it without experimenting as the feedback so far is that people do want to be able to hide stories but think it can't be hidden.
Iteration: --- → 1.26
Keywords: uiwanted
Priority: -- → P2
Iteration: 1.26 → 1.27
Iteration: 1.27 → 60.1 - Jan 29
Iteration: 60.1 - Jan 29 → 60.3 - Feb 26
Whiteboard: [AS60MVP]
Assignee: nobody → edilee
This is part of adding the context menu to each section from bug 1437129:

The mockups are here: https://mozilla.invisionapp.com/share/7JFPNDEMRYC#/screens/277739895_New_Tab_-_Base
Assignee: edilee → rrosario
Priority: P2 → P1
Summary: Users having difficulty knowing how to hide sections in New Tab → Add section context menu to help users who have difficulty hiding sections
Whiteboard: [AS60MVP] → [strings needed][AS60MVP]
Duplicate of this bug: 1437129
uiwanted: With the (?) info doorhanger going away, where should the pocket Privacy Notice appear?
Keywords: uiwanted
uiwanted: Initial l10n feedback is that inserting the section title is tricky for localization, e.g., "Manage {section}" (I would guess gender matching, etc.) Is it possible to use some other string?
uifeedback: Switching to just "Manage Section" (like the other "Collapse Section"). Also the "About Pocket" should just be "Privacy Notice" pointing to https://www.mozilla.org/en-US/privacy/firefox/#suggest-relevant-content
Keywords: uiwanted
Blocks: 1433199
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1440772
Blocks: 1440792
Blocks: 1433212
Blocks: 1440970
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Firefox: 60.0a1, Build ID 20180226100105

I have verified this issue on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12 with the latest Nightly build (60.0a1) installed. Now the option "Manage section", that is displayed in all the sections menus, opens the "New Tab Preferences" panel until it will be removed.
Also the "Recommended by Pocket" "Privacy Notice" option is displayed in the section menu.
Status: RESOLVED → VERIFIED
Strings landed for localization in https://github.com/mozilla/activity-stream-l10n/pull/11
Whiteboard: [strings needed][AS60MVP] → [strings landed][AS60MVP]
Blocks: 1444980
Blocks: 1425500
Blocks: 1451600
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.