Firefox on Android does not recognize font-family:Roboto-Regular, whereas Android Blink browsers do.

RESOLVED INVALID

Status

()

Core
Graphics: Text
RESOLVED INVALID
2 months ago
2 months ago

People

(Reporter: Thomas Wisniewski, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
webcompat ?

Firefox Tracking Flags

(firefox59 affected)

Details

(Whiteboard: [webcompat])

(Reporter)

Description

2 months ago
I've just confirmed that Firefox 57 and today's nightly do not find "font-family:Roboto-Regular" on a Samsung Galaxy S7 Edge phone (Android 7.0) and a Nexus 7 tablet (Android 5.1.1), while Blink does find it on both devices.

This is causing some webcompat issues on tier-1 Google pages, as Firefox is falling back to Clear Sans, which has different metrics and breaks some layout assumptions that Google is making (changing to "Roboto" instead of "Roboto-Regular" fixes it).

It's probably best for us to consider adopting whatever mechanism allows Blink to discover fonts with this naming convention (if we weren't already doing so and it broke).
Flags: webcompat?
Recognizing "font-family: Roboto-Regular" is a clear violation of the CSS Fonts spec. That's not a font family name, it is the PostScript name of an individual font face.

This is a known Blink bug, see https://bugs.chromium.org/p/chromium/issues/detail?id=641861.
(Reporter)

Comment 2

2 months ago
I see, thanks. Then since the Blink team has acknowledged the bug, let's close this for now (we'll reach out to have those pages adjusted appropriately to not use the PostScript font name).
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.