Closed Bug 142221 Opened 23 years ago Closed 23 years ago

100k of bloat at each reload

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 81446

People

(Reporter: jwz, Assigned: Matti)

Details

Attachments

(1 file)

I don't know whether these kinds of reports are even remotely useful
to you, or what to report them against, but I guess there's only one
way to find out... report it and see who yells at me.

I'm seeing Mozilla 0.9.9 grow by 100k each time a small auto-refreshing
document reloads.  It reached 154M after 6 days of being mostly idle
but for this reloading window.

gtop's resident memory display shows 6 mozilla-bin processes consuming
154368k.  (I don't know whether gtop is sextuple-counting the memory,
or whether it's smart about shared pages.  If you know, tell me!)

For comparison, X is 2660k and httpd (9 threads) is 21388k.

This Mozilla process was launched on April 30.  It is now May 4.  I've
only been here on two of those days, and I've only been sitting in
front of the browser for maybe 4 hours total over those 5-6 days.
Mostly I read slashdot and livejournal: nothing too exotic.  However,
one of the pages that has been visible in a window is a small (~15
line) constantly-changing HTML document with a 30 second refresh.

With that 6-day Mozilla running, top said:

  4:07am  up 48 days, 22:06, 1 user, load average: 0.71, 1.78, 1.54
  98 processes: 84 sleeping, 2 running, 8 zombie, 4 stopped
  CPU states:  0.1% user,  0.6% system,  0.3% nice,  0.3% idle
  Mem: 127824K av, 123668K used, 4156K free, 39884K shrd, 6000K buff
  Swap: 96348K av,  93784K used, 2564K free              25940K cached

I killed Mozilla and top said:

  93 processes: 80 sleeping, 1 running, 8 zombie, 4 stopped
  CPU states:  0.1% user,  0.6% system,  0.3% nice,  0.3% idle
  Mem: 127824K av, 109344K used, 18480K free, 44604K shrd, 3660K buff
  Swap: 96348K av,  81048K used, 15300K free              37496K cached

I launched a new Mozilla and top immediately said:

  101 processes: 84 sleeping, 5 running, 8 zombie, 4 stopped
  CPU states: 39.6% user, 32.4% system,  0.0% nice, 27.9% idle
  Mem: 127824K av,125004K used,  2820K free, 58460K shrd, 3720K buff
  Swap: 96348K av, 80232K used, 16116K free              42140K cached

I loaded the frameset that contains the reloading document (which is
my internal, non-demo version of http://www.jwz.org/gronk/demo/).

Each time the timer went off, or I clicked on an "X" to delete a song
and make the list reload, Mozilla grew.  According to the resident
usage display in gtop, it grew like so:

    mozilla-bin (5) 116980k
    mozilla-bin (6) 117060k
    mozilla-bin (6) 142008k
    mozilla-bin (6) 142176k
    mozilla-bin (6) 143160k

Ouch!

Generally, I find Mozilla to consume more memory faster than Netscape
4.7whatever did.  The top displays make it obvious why my machine is
hurting: it's swapping, and swapping on Linux is most non-triumphant.
However, as I said, I didn't feel the need to purchase more RAM when I
was still running NS4.
This is a sample of the document that is auto-reloading in the
upper left cell of a frameset that looks much like
http://www.jwz.org/gronk/demo/
Dupe of bug 81446

*** This bug has been marked as a duplicate of 81446 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: