utwente.nl - Windows networking not supported

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Dutch
P5
normal
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Thijs, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Windows networking links (e.g.: \\computername\share) are not supported. "dance"
and my computer are on the same lan so it should work. in ie6 it does anyway.

greets thijs

Comment 1

16 years ago
It works, but there're bugs.
Try file://///dance/dir as initial dir doesn't work (known bug)
Thijs, where are you putting this Windows Networking path, exactly?
oh, and this is file networking
Assignee: aaronl → dougt
Component: Accessibility APIs → Networking: File
QA Contact: dsirnapalli → benc

Comment 4

16 years ago
dup of bug 120957?
(Reporter)

Comment 5

16 years ago
i think i see the problem now. in the html-source, there's this link:

<a class="hit" href="\\130.89.163.18\FILMS\Friends">blabla</a>

but when i move my mousepointer over the link in mozilla, i see the
following text in the statusbar:

http://dance/\\130.89.163.18\FILMS\Friends ,

which is obviously not the right path. mozilla seems not to "understand"
that this is an ABSOLUTE path, and not relative!
and of course windows networking has nothing to do with the http protocol
either.
Ah, I see.  The problem is the use of invalid "\" characters in a url.  We do
not support that, iirc (except in the URLbar).  Over to darin for confirmation.
Assignee: dougt → darin
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
yup, we cannot support that broken URL syntax without breaking other valid URLs.

-> tech evangelism
Assignee: darin → doron
Component: Networking: File → US General
Product: Browser → Tech Evangelism
QA Contact: benc → zach
Version: other → unspecified

Comment 8

16 years ago
confirmed, don't use \ in links, that is just a normal char not a path
delimiter. The correct link should look like: 

<a class="hit" href="file://///130.89.163.18/FILMS/Friends">blabla</a>

However this link may still be blocked if you access it through http because it
would count as a security violation. If you access it over the file protocol it
should work, modulo the problems we have with UNC paths.

Comment 9

15 years ago
-> euro w
Assignee: doron → nitot
Component: US General → Europe: West
QA Contact: zach → brantgurganus2001
Summary: Windows networking not supported → utwente.nl - Windows networking not supported

Comment 10

15 years ago
tech evang june 2003 reorg
Assignee: nitot → dutch
Component: Europe: West → Dutch
QA Contact: brantgurganus2001 → dutch

Comment 11

15 years ago
June 2003 : prioritizing Dutch Tech evangs
Priority: -- → P5
links have changed, WFM
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 13

13 years ago
that would be fixed then...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

13 years ago
--> fixing
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.