Update MOZ_LOG modules list for about:networking#logging to a better list

RESOLVED FIXED in Firefox 58

Status

()

defect
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Trunk
mozilla59
Points:
---

Firefox Tracking Flags

(firefox58 fixed, firefox59 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

let's have:

timestamp,nsHttp:5,cache2:5,nsSocketTransport:5,nsHostResolver:5

this is controlled with "logging.<module_name>" = <level> preferences.

P2 as this positively influences convenience of all external bug reports analyzes.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Posted patch v1Splinter Review
Attachment #8933715 - Flags: review?(valentin.gosu)
Attachment #8933715 - Flags: review?(valentin.gosu) → review+
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f848a44b2868
Update about:networking#logging default list of logs to a more useful list, r=valentin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f848a44b2868
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8933715 [details] [diff] [review]
v1

Since this may really help when diagnosing networking related bugs, I'd like to get this to at least Beta (if there is a plan for 57 dot release, it would be nice to take these as well)

Approval Request Comment
[Feature/Bug causing the regression]: none
[User impact if declined]: two steps when asking for logs (first w/o important modules, second with "please modify the list as bla bla and do again")
[Is this code covered by automated tests?]: n/a
[Has the fix been verified in Nightly?]: yes!  manually
[Needs manual test from QE? If yes, steps to reproduce]: n/a
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: just changes a default value of a field on a diagnostic page, zero user impact otherwise
[String changes made/needed]: none
Attachment #8933715 - Flags: approval-mozilla-beta?
Note: related MDN document has been updated.
Comment on attachment 8933715 [details] [diff] [review]
v1

For help diagnosing networking related bugs. Beta58+.
Attachment #8933715 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.