Closed Bug 1422478 Opened 5 years ago Closed 5 years ago

Regression: The New Tab Button is overlapped by the new tab during a tabcreation

Categories

(Firefox :: Theme, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- verified
firefox59 --- verified

People

(Reporter: mehmet.sahin, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached video expected.mov
FF58 Beta and Nightly 59.0a1 (2017-12-01) (64-Bit)
macOS 10.12.6 (but probably OS=All)

STR:

1.) Open tabs via short-key (CMD-T)
2.) Take a look at the New Tab Button

Actual: The New Tab creation is overlapping the NewTab Button.

Expected: No overlapping.

Screencasts (expected vs. actual) are attached.
Attached video actual.mov
The regression range is:

Last Good: 2017-10-06-10-03-27-mozilla-central

First Bad: 2017-10-07-10-01-42-mozilla-central

Looks like https://hg.mozilla.org/mozilla-central/rev/40ef1df3618b could be the culprit.

Johann: Could you please take a look at the regression? Please feel free to close this report, if you think we can live with this edge case.

Thanks.
Blocks: 1391539
Flags: needinfo?(jhofmann)
Hm, I agree that it's a bug, though I'm not sure anyone will actively look for a fix anytime soon. (Maybe don't show the separators during the transition?).

Thanks for reporting!
Flags: needinfo?(jhofmann)
Priority: -- → P5
Keywords: regression
Priority: P5 → P3
Comment on attachment 8936543 [details]
Bug 1422478 - Prevent tab separator from overlapping the new tab button during the tab open animation.

https://reviewboard.mozilla.org/r/207258/#review213104

Looks great, thanks! :)
Attachment #8936543 - Flags: review?(jhofmann) → review+
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/63e7232485b6
Prevent tab separator from overlapping the new tab button during the tab open animation. r=johannh
https://hg.mozilla.org/mozilla-central/rev/63e7232485b6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Attached video flicker.mov
Thanks! Looks good in 59.0a1 (2017-12-14) (64-Bit) on macOS 10.12.6.

I just only noticed a flicker with the 3 last opening tab animation before the Overflow button appears. The flicker is a overlapping of the tab crating animation on left edge of the NewTab Button. (This wasn't the case, before the initial regression of this bug happened.)

A screencast is attached. Can we live with this? 

Thanks.
Flags: needinfo?(dao+bmo)
(In reply to Mehmet from comment #8)
> Created attachment 8936873 [details]
> flicker.mov
> 
> Thanks! Looks good in 59.0a1 (2017-12-14) (64-Bit) on macOS 10.12.6.
> 
> I just only noticed a flicker with the 3 last opening tab animation before
> the Overflow button appears. The flicker is a overlapping of the tab crating
> animation on left edge of the NewTab Button. (This wasn't the case, before
> the initial regression of this bug happened.)
> 
> A screencast is attached. Can we live with this? 
> 
> Thanks.

Might be worth looking into. Can you please file a new bug on this? Thanks.
Flags: needinfo?(dao+bmo)
Comment on attachment 8936543 [details]
Bug 1422478 - Prevent tab separator from overlapping the new tab button during the tab open animation.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1391539
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: kind of (comment 8)
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: straightforward CSS-only fix
[String changes made/needed]:
Attachment #8936543 - Flags: approval-mozilla-beta?
(In reply to Dão Gottwald [::dao] from comment #9)
> Might be worth looking into. Can you please file a new bug on this? Thanks.

Done: Bug 1425281 :-)
Comment on attachment 8936543 [details]
Bug 1422478 - Prevent tab separator from overlapping the new tab button during the tab open animation.

Minor css fix. Since the problem can be annoying to users, and the risk is low, let's uplift.
Attachment #8936543 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [good first verify]
As per STR in comment0,I tried to reproduce. The bug is fixed & verified and no longer reproducible.

Browser: Firefox Nightly 59.0a1  [Build ID:20180114100259]
         Firefox Quantum 58.0b16 [Build ID:20180111124119]

OS: Windows 10.0 X 64-bit
[bugday-20170108]
(In reply to Fahima Zulfath from comment #14)
> As per STR in comment0,I tried to reproduce. The bug is fixed & verified and
> no longer reproducible.
> 
> Browser: Firefox Nightly 59.0a1  [Build ID:20180114100259]
>          Firefox Quantum 58.0b16 [Build ID:20180111124119]
> 
> OS: Windows 10.0 X 64-bit
> [bugday-20170108]


[bugday-20170110]
You need to log in before you can comment on or make changes to this bug.