Closed Bug 1422543 Opened 3 years ago Closed 3 years ago

XML Parsing Error: undefined entity in glodaFacetView.xhtml — introduced in Daily 1121

Categories

(Thunderbird :: Search, defect)

x86_64
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: calum.mackay, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file)

Gloda search works fine in Daily 1120, but in Daily 1121, Cmd-K results in:

====
XML Parsing Error: undefined entity
Location: jar:file:///Applications/Daily.app/Contents/Resources/omni.ja!/chrome/messenger/content/messenger/glodaFacetView.xhtml
Line Number 17, Column 1:
<html xmlns="http://www.w3.org/1999/xhtml"
^
====

Nothing further in the console.

1121 is the latest Mac build I could find.
glodaFacetView.xhtml hasn't changed since Feburary, and that line looks as it does in the source, so something in the parser?
http://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/ has a Daily of today.

I can confirm the problem on Windows in a local build which is a few days old, later than 21st Nov.

Alice, can you find the regression?
Flags: needinfo?(alice0775)
about.dtd was removed in m-c and glodaFacetView.xhtml still referenced to this.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(alice0775)
Attachment #8933961 - Flags: review?(jorgk)
It was removed in bug 1408044.
Comment on attachment 8933961 [details] [diff] [review]
no-about.dtd.patch

Thanks, that fixed Gloda for me. I'll get this landed before the next Daily.
Attachment #8933961 - Flags: review?(jorgk) → review+
Blocks: 1408044
Keywords: regression
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/722cc2e9d87d
Remove reference to the removed about.dtd. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Thanks very much all for the quick fix.

(In reply to Jorg K (GMT+1) from comment #2)
> http://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/ has a
> Daily of today.

sorry; yet again I'm caught out by the build dir having both 58 & 59 and I was wrongly looking at the older one.

Although I normally use the localised en-GB Mac build, which /is/ stuck at 1121 for 59.
You need to log in before you can comment on or make changes to this bug.