Device preview shows empty page

RESOLVED DUPLICATE of bug 1407830

Status

()

Firefox
Developer Tools: Responsive Design Mode
P1
normal
RESOLVED DUPLICATE of bug 1407830
2 months ago
a month ago

People

(Reporter: Yves Goergen, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171112125346

Steps to reproduce:

* Open any website in Firefox for Windows (desktop)
* Enable device preview (Ctrl+Shift+M)


Actual results:

Sometimes, the page is displayed in the smaller viewport. Sometimes a blank page is displayed. Reloading doesn't fix it. To fix it, close the tab and then retry in a new tab. Sometimes the blank page remains blank when leaving that device preview mode. So the entire tab is effectively broken and will not load anything anymore. Never.

Updated

2 months ago
Component: Untriaged → Developer Tools: Responsive Design Mode
Thanks for filing!  I agree that's quite frustrating!

We made some improvements on this front in Firefox 58, but it's possible there's still more to do.

What version of Firefox where you testing here?  If it's earlier than 58, could you try Nightly (now 59)?
Flags: needinfo?(nospam)
Priority: -- → P1
(Reporter)

Comment 2

a month ago
I am using the latest stable, now 57. I could test nightly, but the bug is not reproducible. I don't know what site I had the problem with so I can't verify there's any difference in nightly.
Flags: needinfo?(nospam)
Okay!  In the past, I've usually triggered the issue by toggling RDM open and closed from the keyboard (Ctrl-Shift-M on Windows), and eventually it would break like you describe within ~20 attempts if it was going to happen at all.

It shouldn't really depend to much on the page being viewed.

Let's assume it's fixed by 58 and above for now.  If you discover that it's not, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1407830
You need to log in before you can comment on or make changes to this bug.