Closed Bug 1422674 Opened 2 years ago Closed 2 years ago

IAccessible::accChild on parent process accessibles fails with positive indexes

Categories

(Core :: Disability Access APIs, defect)

All
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: Jamie, Assigned: Jamie)

References

Details

(Keywords: regression)

Attachments

(1 file)

Spun off bug 1422201 comment 13.

STR:
1. Start NVDA and Firefox.
2. Open about:support.
3. Ensure the document is focused.
4. Open the NVDA Python console with NVDA+control+z.
5. Enter: focus.IAccessibleObject.accChild(1)
Expected: An IAccessible.
Actual: Exception.
6. Open a remote document; e.g. mozilla.org.
7. Ensure the document is focused.
8. Open the NVDA Python console with NVDA+control+z.
9. Enter: focus.IAccessibleObject.accChild(1)
10. Observe that you get an IAccessible as expected.

I think that this is because AccessibleWrap::GetRemoteIAccessibleFor calls GetRemoteIAccessibleFor if this isn't a chrome accessible:

if (XRE_IsParentProcess() && !IsProxy() && !sIDGen.IsChromeID(varChild.lVal)) {

but it doesn't first check that this is a negative id. I don't think !sIDGen.IsChromeID knows about positive ids, so it's going to answer that it isn't a chrome id. Thus, GetRemoteIAccessibleFor gets called, which will of course fail. This is all educated guesswork right now, though; I haven't done any actual debugging.

Low priority because I don't know of any clients that actually need this.
Regression introduced by bug 1304449 (Firefox 52). Trivial fix, so I'm just going to do this now while it's in my head.
Assignee: nobody → jteh
Keywords: regression
Comment on attachment 8934752 [details]
Bug 1422674: Fix IAccessible::accChild on parent process accessibles with positive indices.

https://reviewboard.mozilla.org/r/205632/#review211290
Attachment #8934752 - Flags: review?(mzehe) → review+
Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce401a7898ee
Fix IAccessible::accChild on parent process accessibles with positive indices. r=MarcoZ
https://hg.mozilla.org/mozilla-central/rev/ce401a7898ee
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Given where we are in the cycle and that this isn't a new regression, I'm calling this wontfix for 58. Feel free to set the status to affected and nominate it for Beta approval if you feel strongly otherwise.
Duplicate of this bug: 1363026
Duplicate of this bug: 1370219
You need to log in before you can comment on or make changes to this bug.