Closed Bug 1422709 Opened 4 years ago Closed 4 years ago

Scaling issues on mixed DPI screens on Wayland Gnome

Categories

(Core :: Widget: Gtk, defect, P3)

57 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1431337

People

(Reporter: luis.pabon, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: dpi)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171129230227

Steps to reproduce:

Ubuntu 17.10, FF 57, Wayland, 4k laptop display (main display) with a scaling of 2, 2k external displays.


Actual results:

I have a 4K laptop which I regularly connect to 1080 or 720p monitors. Firefox scales correctly on the HiDPI monitor, but looks twice as big on the lower DPI monitor.

Gnome will correctly scale other GTK applications according to the screen they're on.




Expected results:

Firefox should re-scale itself when moved from a HiDPI display to a lower DPI display as all other gnome applications do.
Attached image All screens screenshot
Below: 4k screen with file manager (for comparison) and normally looking FF
Above: screen is 2K and has file manager, Epiphany browser (both scale correctly), and Firefox looking 2x too big
Component: Untriaged → Widget: Gtk
Keywords: dpi
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1431337
You need to log in before you can comment on or make changes to this bug.