Closed Bug 1422794 Opened 2 years ago Closed 2 years ago

Crash in nsTArray_Impl<T>::~nsTArray_Impl | mozilla::layers::AsyncPanZoomAnimation::~AsyncPanZoomAnimation

Categories

(Core :: Canvas: WebGL, defect, P3, critical)

Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1421313
Tracking Status
firefox59 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression, Whiteboard: [gfx-noted])

Crash Data

This bug was filed from the Socorro interface and is
report bp-0e5a75ef-7a0f-4758-a9c4-a84080171202.
=============================================================

Seen while looking at nightly Android crash stats: http://bit.ly/2klX84n. Relatively small volume on Nightly, but affects a few popular devices and they are all unique users. Crashes started using 20171129111022.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5b33b070378ae0806bed0b5e5e34de429a29e7db&tochange=3f6b9aaed8cd57954e0c960cde06d25228196456

Top 10 frames of crashing thread:

0 libxul.so nsTArray_Impl&lt;RefPtr&lt;mozilla::Runnable&gt;, nsTArrayInfallibleAllocator&gt;::~nsTArray_Impl xpcom/ds/nsTArray.h:400
1 libxul.so mozilla::layers::AsyncPanZoomAnimation::~AsyncPanZoomAnimation gfx/layers/apz/src/AsyncPanZoomAnimation.h:74
2 libxul.so mozilla::gl::GLContext::MakeCurrent gfx/gl/GLContext.cpp:3047
3 libxul.so mozilla::gl::TexturePoolOGL::Fill gfx/layers/opengl/TexturePoolOGL.cpp:104
4 libxul.so mozilla::layers::CompositorOGL::BeginFrame gfx/layers/opengl/CompositorOGL.cpp:677
5 libxul.so mozilla::layers::LayerManagerComposite::Render gfx/layers/composite/LayerManagerComposite.cpp:917
6 libxul.so mozilla::layers::LayerManagerComposite::UpdateAndRender gfx/layers/composite/LayerManagerComposite.cpp:533
7 libxul.so mozilla::layers::LayerManagerComposite::EndTransaction gfx/layers/composite/LayerManagerComposite.cpp:463
8 libxul.so mozilla::layers::CompositorBridgeParent::CompositeToTarget gfx/layers/ipc/CompositorBridgeParent.cpp:1043
9 libxul.so mozilla::layers::CompositorVsyncScheduler::Composite gfx/layers/ipc/CompositorVsyncScheduler.cpp:388

=============================================================
This crash stack doesn't make much sense. Frames 2-9 seem fine, but I don't see how MakeCurrent would call into ~AsyncPanZoomAnimation or nsTArray. I suspect those frames are bogus or got mis-symbolicated or something. From the regression range bug 1390386 looks like the most likely culprit - jgilbert, could you take a look?
Component: Panning and Zooming → Canvas: WebGL
Flags: needinfo?(jgilbert)
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jgilbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1421313
You need to log in before you can comment on or make changes to this bug.