Closed Bug 1422827 Opened 2 years ago Closed 2 years ago

Crash in mozalloc_abort | abort | gleam::ffi_gl::missing_fn_panic

Categories

(Core :: Graphics: WebRender, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1421549

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-f0930677-2178-4967-9e28-6889e0171203.
=============================================================

Seen while looking at crash stats: http://bit.ly/2AJOx1T. Comment says "I tried to enable webrender in firefox nightly and now I can't really open it anymore"

Top 10 frames of crashing thread:

0 firefox mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:33
1 firefox abort memory/mozalloc/mozalloc_abort.cpp:80
2 libxul.so std::panicking::rust_panic src/libpanic_abort/lib.rs:59
3 libxul.so std::panicking::rust_panic_with_hook src/libstd/panicking.rs:593
4 libxul.so std::panicking::begin_panic<&str> src/libstd/panicking.rs:538
5 libxul.so gleam::ffi_gl::missing_fn_panic toolkit/library/x86_64-unknown-linux-gnu/release/build/gleam-3f78fb01dd699e52/out/gl_bindings.rs:993
6 libxul.so webrender::device::Device::begin_frame gfx/webrender/src/device.rs:722
7 libxul.so webrender::renderer::Renderer::new gfx/webrender/src/renderer.rs:1514
8 libxul.so webrender_bindings::bindings::wr_window_new gfx/webrender_bindings/src/bindings.rs:747
9 libxul.so mozilla::wr::NewRenderer::Run gfx/webrender_bindings/WebRenderAPI.cpp:74

=============================================================
Whiteboard: [wr-mvp] [triage]
Blocks: wr-stability
Hardware: Unspecified → x86_64
It seems like a dup of Bug 1421549. It was merged to m-c today.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1421549
Whiteboard: [wr-mvp] [triage]
You need to log in before you can comment on or make changes to this bug.