Assertion failure in UnregisterDataSource

VERIFIED DUPLICATE of bug 14755

Status

P3
normal
VERIFIED DUPLICATE of bug 14755
19 years ago
2 months ago

People

(Reporter: phil, Assigned: waterson)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
My browser was sitting idle when this assertion failure fired. Maybe related to
a sidebar update? I see this assertion failure fairly frequently.

NTDLL! 77f7629c()
nsDebug::Assertion(const char * 0x60a57798, const char * 0x60a57788, const char
* 0x60a5775c, int 0x000003ee) line 181 + 13 bytes
RDFServiceImpl::UnregisterDataSource(RDFServiceImpl * const 0x009eb810,
nsIRDFDataSource * 0x01d1dd80) line 1006 + 34 bytes
RDFXMLDataSourceImpl::~RDFXMLDataSourceImpl() line 471 + 22 bytes
RDFXMLDataSourceImpl::`scalar deleting destructor'(unsigned int 0x00000001) + 15
bytes
RDFXMLDataSourceImpl::Release(RDFXMLDataSourceImpl * const 0x01d1dd80) line 510
+ 99 bytes
nsCOMPtr<nsIRDFDataSource>::~nsCOMPtr<nsIRDFDataSource>() line 458
ContainerEnumeratorImpl::~ContainerEnumeratorImpl() line 116 + 33 bytes
ContainerEnumeratorImpl::`scalar deleting destructor'(unsigned int 0x00000001) +
15 bytes
ContainerEnumeratorImpl::Release(ContainerEnumeratorImpl * const 0x02959610)
line 118 + 96 bytes
nsXPCWrappedNative::~nsXPCWrappedNative() line 332 + 27 bytes
nsXPCWrappedNative::`scalar deleting destructor'(unsigned int 0x00000001) + 15
bytes
nsXPCWrappedNative::Release(nsXPCWrappedNative * const 0x02959440) line 49 + 31
bytes
nsXPCWrappedNative::JSObjectFinalized(JSContext * 0x01bb7170, JSObject *
0x0201be68) line 74
WrappedNative_Finalize(JSContext * 0x01bb7170, JSObject * 0x0201be68) line 604
js_FinalizeObject(JSContext * 0x01bb7170, JSObject * 0x0201be68) line 1259 + 114
bytes
js_GC(JSContext * 0x01bb7170) line 844 + 11 bytes
js_ForceGC(JSContext * 0x01bb7170) line 627 + 9 bytes
JS_GC(JSContext * 0x01bb7170) line 1079 + 9 bytes
nsJSContext::GC(nsJSContext * const 0x01b71a10) line 347 + 13 bytes
GlobalWindowImpl::SetNewDocument(GlobalWindowImpl * const 0x01bae864,
nsIDOMDocument * 0x00000000) line 335
DocumentViewerImpl::~DocumentViewerImpl() line 279
DocumentViewerImpl::`scalar deleting destructor'(unsigned int 0x00000001) + 15
bytes
DocumentViewerImpl::Release(DocumentViewerImpl * const 0x02d272a0) line 237 + 99
bytes
nsWebShell::Embed(nsWebShell * const 0x01851e10, nsIContentViewer * 0x02d2e730,
const char * 0x02d2c8c0, nsISupports * 0x00000000) line 856 + 27 bytes
nsDocumentBindInfo::OnStartRequest(nsDocumentBindInfo * const 0x02d28c90,
nsIChannel * 0x02d28e50, nsISupports * 0x00000000) line 1285 + 36 bytes
nsChannelListener::OnStartRequest(nsChannelListener * const 0x02d28f20,
nsIChannel * 0x02d28e50, nsISupports * 0x00000000) line 1535 + 43 bytes
nsHTTPResponseListener::FinishedResponseHeaders() line 680 + 37 bytes
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x02d2c910, nsIChannel * 0x02d2d620, nsISupports * 0x02d28e50, nsIInputStream *
0x02d2c798, unsigned int 0x00000000, unsigned int 0x00000385) line 166 + 8 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x02d284f0)
line 345
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x02d284f4) line 144 + 12 bytes
PL_HandleEvent(PLEvent * 0x02d284f4) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00997770) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0abb0360, unsigned int 0x0000c0e5, unsigned int
0x00000000, long 0x00997770) line 938 + 9 bytes
USER32! 77e71820()
00997770()
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
dup: fix ready to go pending chofmann's approval.

*** This bug has been marked as a duplicate of 14755 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
verified duplicate of 14755

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.