Closed Bug 1422979 Opened 4 years ago Closed 4 years ago

Update bmpsuite to version 2.5

Categories

(Core :: ImageLib, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

References

Details

Attachments

(2 files)

We've not updated bmpsuite since it landed in bug 1204394. It's now at version 2.5:

http://entropymine.com/jason/bmpsuite/
Comment on attachment 8934308 [details]
Bug 1422979, part 1 - Increase bmpsuite reftest fuzz for HiDPI.

https://reviewboard.mozilla.org/r/205222/#review210786

::: commit-message-f690e:1
(Diff revision 1)
> +Bug 1422979, part 1 - Increase bmpsuite reftest fuzz for HiDPI. r=njn

This is just the fuzz increase that I needed to add to pass locally on my mbp.
To be clear, the fuzz that I needed to add to get the _existing_ tests passing locally before making changes.
For anyone repeating this at some point in the future, the lines that look like:

# BMP: bihsize=40, 127 x 64, bpp=8, compression=1, colors=253

come from exporting MOZ_LOG="BMPDecoder:5" in your shell before running the reftests (I copied and pasted into the reftest.list files manually).
Comment on attachment 8934308 [details]
Bug 1422979, part 1 - Increase bmpsuite reftest fuzz for HiDPI.

https://reviewboard.mozilla.org/r/205222/#review210798
Attachment #8934308 - Flags: review?(n.nethercote) → review+
Comment on attachment 8934309 [details]
Bug 1422979, part 2 - Update to bmpsuite 2.5.

https://reviewboard.mozilla.org/r/205224/#review210800
Attachment #8934309 - Flags: review?(n.nethercote) → review+
Thank you for doing this. I'm pleased that the BMP decoder didn't need any changes to handle the extra tests!

> For anyone repeating this at some point in the future, the lines that look
> like:
> 
> # BMP: bihsize=40, 127 x 64, bpp=8, compression=1, colors=253
> 
> come from exporting MOZ_LOG="BMPDecoder:5" in your shell before running the
> reftests (I copied and pasted into the reftest.list files manually).

That would be useful information to put into the file :)
(In reply to Nicholas Nethercote [:njn] from comment #8)
> Thank you for doing this. I'm pleased that the BMP decoder didn't need any
> changes to handle the extra tests!

It's worth noting that bmpsuite doesn't have renderings for some of the new "b/" (bad) images, so I added them (we match Chrome, which seemed good enough).

And I'm currently I'm waiting for feedback on:

https://github.com/jsummers/bmpsuite/issues/6
https://github.com/jsummers/bmpsuite/issues/7

I'll file bugs if appropriate after I've received feedback on those bugs.
Needinfo'ing you just to make sure you've seen comment 9, in case that matters to you.
Flags: needinfo?(n.nethercote)
Duplicate of this bug: 1222303
Thank you for the extra info. I trust you to handle these cases sensibly :)
Flags: needinfo?(n.nethercote)
I'll do my best. ;)
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9ca915d24f97
part 1 - Increase bmpsuite reftest fuzz for HiDPI. r=njn
https://hg.mozilla.org/integration/mozilla-inbound/rev/9e12b2ed4a44
part 2 - Update the bmpsuite test suite to version 2.5. r=njn
https://hg.mozilla.org/mozilla-central/rev/9ca915d24f97
https://hg.mozilla.org/mozilla-central/rev/9e12b2ed4a44
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.