input select borders not showing

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Marcello Bastéa-Forte, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020501
BuildID:    2002050108

When using CSS to override input check/radio boxes and select form box borders,
Netscape 6.2 shows the custom borders, but the latest Mozilla's do not.  

Reproducible: Always
Steps to Reproduce:
1. Create a form with input checkbox, radiobox, and select box
2. use css code: input,select { border: solid 2px red }
3. Look at it

Actual Results:  The borders remain the standard format.

Expected Results:  The borders should be red.
Created attachment 82351 [details]
testcase
This worksforme with a current build.  The border color changes, the width and
style do not for the select but do for the input (by design).  The borders on
the site also look correct (dotted, white, 1px).

Can you point to a testcase that reproduces this bug?
(Reporter)

Comment 3

16 years ago
Created attachment 82359 [details]
Border Test

These all have solid blue 3pixel borders on Netscape 6.2, but not on any of the
recent mozilla builds I've tried (2002050108 right now).
Ah, I see. I can reproduce this if I turn on XBL form controls...  Go to Edit >
Preferences > Debug, second-to-last checkbox in the middle section.  Is that
checked?
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 5

16 years ago
If I turn on that option:
All elements have the proper border width.  The radio input and text input have
the proper border colors.  The checkbox input and select boxes have the system
colors.  The actual workings of the checkbox and radio boxes are completely
messed up in this mode, however.
wait.... if you turn _on_ this option the colors are correct?  In my case things
look like this (both trunk and branch on Linux):

1)  With XBL controls _on_, the borders are wrong
2)  With XBL controls _off_, the borders are correct

(resetting OS field, which I accidentally changed)
OS: All → Windows 2000
Hardware: All → PC
(Reporter)

Comment 7

16 years ago
On or off, the text input box works.
On: radio boxes have proper color/thickness, checkboxes and select boxes have
proper thickness (not color or style)
Off: radio boxes, checkboxes, and select boxes all have the wrong style (the
color seems right, but hard to tell without a solid style)
OK.  I'm seeing exactly what you are then.  This is as-designed -- see the
discussion in bug 134927 and bug 106317.  We allow modification of the border
color on all controls, but not modification of border style/width on
select/radio/checkbox...  Allowing modification of those borders leads to those
controls being invisible or very hard to use on a number of sites,
unfortunately.

Marking invalid, since the behavior is what it should be....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.