failed to attach binary files

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
P3
major
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Jiun-Yao Huang, Assigned: myk)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Attaching an image file got the following error message:

Software error:
insert into attachments (bug_id, filename, description, mimetype, ispatch, 
submitter_id, thedata) values (36,'D:\\tmp\\logo.gif', 'test', 'image/gif', 0, 
1, 'GIF89a}\0F\0æ\0\0ÿÿÿ÷÷ÿ÷÷÷ï÷÷ÿï÷ÿïïïïïïï÷æï÷ææ÷ææ?ÞæÞæï÷ÞÞÞÞïÞÞÞ÷ÖÖ÷ÖÞÖÞïæÖæÖÖ

[Snip]

quot;l]?YlKG?Yl^7?]b?N??]5D§l\'NlS?Y???\0;'): You have an error in 
your SQL syntax near 'N?\02öø#"ru©È‘ÎA?{Ñq?{VXg\0C&§à?Èu?quot;*ºW?ÖùÇÉŸà¥\0^™É�Á
‚{{?amp;—n‰ôù\\¥aÊɇî' at line 1 at globals.pl line 215, <STDIN> line 34.

I think this is because the sql syntax contains invalid string patterns
that causes $::currentquery->execute failed (in global.pl line 215),
even the string was translated by SqlQuote.

I have two Bugzilla installations with MySQL on different platforms.
One is on Linux, and the other is on Windows. Both MySQL versions are 3.23.49.
Attaching the image file failed on the Bugzilla with MySQL running on Linux,
but attaching the same file works on the Bugzilla with MySQL running on Windows.

Comment 1

16 years ago
Can you attach a file that triggers this bug when you try to upload it? If you
can't attach it as-is on bugzilla.mozilla.org, can you try to attach a .gz or
.tar file containing it, or maybe even the result of uuencode (a base64
encoder)? Does attaching it on http://landfill.tequilarista.org/bugzilla-tip/
work?
(Reporter)

Comment 2

16 years ago
Created attachment 82383 [details]
the image file failed to attach on my machine
So it fails on unix, but works on windows? Not the other way arround?
(Reporter)

Comment 4

16 years ago
I have two installations:

1) Bugzilla 1.14.1 on Linux, MySQL 3.23.49 on Linux
2) Bugzilla 1.14.1 on Linux, MySQL 3.23.49 on Windows 2000

1) fails, but 2) works.

Comment 5

16 years ago
Apparently this works with the bugzilla-tip installation on landfill, see
http://landfill.tequilarista.org/bugzilla-tip/show_bug.cgi?id=274
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
jyhuang@wizs.org: are you still seeing problems like this? We just started using
CGI.pm for the file upload interface, so that should be even more compatible...

Gerv
Id this was the other way arround, it would be a dupe of bug 62000
No followup; WORKSFORME.

Gerv
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.