Closed Bug 1423204 Opened 2 years ago Closed 2 years ago

On sears.com the form autofill doesn't work for address-line1 and address-line2 fields

Categories

(Toolkit :: Form Autofill, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox59 --- verified

People

(Reporter: Ovidiu, Assigned: selee)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(3 files)

Attached image sears.com bug.png
[Affected versions]:

Tested on Nightly 59.0a1(2017-12-05)

[Affected platforms]:

Tested on Mac 10.13 and Ubuntu 16.04

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profiles.

 
1. Go to www.sears.com
2. Proceed to checkout 
3. From the checkout method choose "Join for free"
4. Click on the fields that are listed

[Expected result]:

A drop down with your profile suggestions should be displayed.  

[Actual result]:

There are no autofill suggestions. 

Note: Only if I click on City or Phone number the suggestions are displayed.
For the rest of fields such as Email, Name and Password, those are set to autocomplete="off" which is desirable that we don't show popup for them. But still, we miss two fields detection about address-line1 and address-line2, so the problem should be more related to heuristic than clear form button. I'm moving this to our web-specific compatibility bug to take care heuristics part. Thanks for reporting this :D
Blocks: formautofill-compatibility
No longer blocks: 1404768
Summary: On sears.com the form autofill doesn't work → On sears.com the form autofill doesn't work for address-line1 and address-line2 fields
I tested this issue using Nightly 59.0a1 with 20171205123322 on Windows 10 x64 and it's also reproducible.
Whiteboard: [form autofill: V2] → [form autofill:V2][Misc.]
See Also: → 1425261
Assignee: nobody → selee
Status: NEW → ASSIGNED
Even the patch fixes the heuristics issue for address-line*, the preview background seems did not cover on the placeholder of each field. However, the filling feature works with the new patch.

BTW, Sears web site seems been updated since the placeholder is different with the previous screenshot.
Comment on attachment 8940498 [details]
Bug 1423204 - Improve the address line parser to detect address-line* more correctly.

https://reviewboard.mozilla.org/r/210736/#review216528

::: browser/extensions/formautofill/FormAutofillHeuristics.jsm:570
(Diff revision 1)
>          // When the field is not related to any address-line[1-3] fields, it
>          // means the parsing process can be terminated.

The comment needs an update since you added one more condition.

::: browser/extensions/formautofill/test/unit/test_getAdaptedProfiles.js:134
(Diff revision 1)
>      profileData: [Object.assign({}, DEFAULT_ADDRESS_RECORD)],
>      expectedResult: [{
>        "guid": "123",
>        "street-address": "2 Harrison St line2 line3",
>        "-moz-street-address-one-line": "2 Harrison St line2 line3",
> -      "address-line1": "2 Harrison St",
> +      "address-line1": "2 Harrison St line2",

nit: add a comment for the purpose of this line.
Attachment #8940498 - Flags: review?(lchang) → review+
Comment on attachment 8940498 [details]
Bug 1423204 - Improve the address line parser to detect address-line* more correctly.

https://reviewboard.mozilla.org/r/210736/#review216560

::: browser/extensions/formautofill/FormAutofillHeuristics.jsm:539
(Diff revision 2)
>     */
>    _parseAddressFields(fieldScanner) {
>      let parsedFields = false;
> -    let addressLines = ["address-line1", "address-line2", "address-line3"];
> -    for (let i = 0; !fieldScanner.parsingFinished && i < addressLines.length; i++) {
> +    const addressLines = ["address-line1", "address-line2", "address-line3"];
> +
> +    // TODO: These address-line* regexps are for the lines with numbers, and

We have to find a way to make them consistent eventually.

BTW, the two issues mentioned above are all updated.
Pushed by lchang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7560a29b0f97
Improve the address line parser to detect address-line* more correctly. r=lchang
https://hg.mozilla.org/mozilla-central/rev/7560a29b0f97
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
I verified this issue using Latest Nightly 59.0a1 with Build ID 20180109100117 on Windows 10 x64 and Mac OS X 10.13 and I can confirm the fix.
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.