Closed Bug 1423240 Opened 3 years ago Closed 3 years ago

Click on the scroll. bar causes it to overshoot mouse position

Categories

(Core :: Widget: Cocoa, defect, P2)

x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1331390

People

(Reporter: ewright, Unassigned)

Details

Attachments

(1 file)

Attached video scroll-bug.mp4
STR: 
- go to a website with a lot of content to trigger a long scrollbar
ex: https://en.wikipedia.org/wiki/New_Zealand

- click and hold on the scrollbar far from the thumb (scroll indicator) to make the thumb slide towards the mouse.

 - the thumb overshoots the mouse by a lot

ER: The thumb scrolls to where the mouse is, and no further

Note: If you click closer to the thumb it will land on the mouse, it seems to build up speed to overshoot when clicking further away

Note: Is not the same as Bug 115232
Component: General → Widget: Cocoa
Product: Firefox → Core
Priority: -- → P2
This is a known regression, tracked in bug 1331390.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331390
You need to log in before you can comment on or make changes to this bug.